summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-14 23:04:34 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-14 23:18:39 +0100
commit5acbfd130891f156116e4fbea689fc6618937df1 (patch)
tree9651aab0ed54fd637a9aff8cb1131314d2f921fd /dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
parentdev-ml/ocamlgsl: Add blocker on dev-ml/gsl-ocaml (diff)
downloadgentoo-5acbfd130891f156116e4fbea689fc6618937df1.tar.gz
gentoo-5acbfd130891f156116e4fbea689fc6618937df1.tar.bz2
gentoo-5acbfd130891f156116e4fbea689fc6618937df1.zip
dev-ml/gsl-ocaml: New package, successor of dev-ml/ocamlgsl
Gentoo-Bug: 574564 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild')
-rw-r--r--dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild b/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
new file mode 100644
index 000000000000..62b3dcb4c5a5
--- /dev/null
+++ b/dev-ml/gsl-ocaml/gsl-ocaml-1.19.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="OCaml bindings for the GSL library (successor of dev-ml/ocamlgsl)"
+HOMEPAGE="https://github.com/mmottl/gsl-ocaml"
+SRC_URI="https://github.com/mmottl/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+DEPEND=">=sci-libs/gsl-1.10"
+RDEPEND="${DEPEND}
+ !dev-ml/ocamlgsl"
+
+DOCS=( CHANGES.txt README.md NOTES.md TODO.md )
+
+src_prepare() {
+ oasis_configure_opts="$(use_enable examples)"
+}