summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-05-23 16:00:27 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-05-24 13:07:15 +0200
commit2376952c95be988f1add2ffb45f175d8681c7653 (patch)
tree2df8077ddece627ba508fccec471daa9139f4c04 /dev-ml/integers/integers-0.2.2.ebuild
parentdev-ml/oasis: Bump to 0.4.10 (diff)
downloadgentoo-2376952c95be988f1add2ffb45f175d8681c7653.tar.gz
gentoo-2376952c95be988f1add2ffb45f175d8681c7653.tar.bz2
gentoo-2376952c95be988f1add2ffb45f175d8681c7653.zip
dev-ml/integers: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/integers/integers-0.2.2.ebuild')
-rw-r--r--dev-ml/integers/integers-0.2.2.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/integers/integers-0.2.2.ebuild b/dev-ml/integers/integers-0.2.2.ebuild
new file mode 100644
index 000000000000..7bb1dc4041c6
--- /dev/null
+++ b/dev-ml/integers/integers-0.2.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Various signed and unsigned integer types for OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-integers"
+SRC_URI="https://github.com/ocamllabs/ocaml-integers/releases/download/v${PV}/${P}.tbz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-lang/ocaml:="
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild
+ dev-ml/topkg
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}