summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-30 23:29:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-30 23:29:49 +0100
commitcd29c7eeee749bca9c856baa462570632dee1934 (patch)
treef106f3ad119ab43e96ba5c91a898beff1959608b /dev-ml/js-build-tools/js-build-tools-113.33.06.ebuild
parentdev-ml/ppx_assert: bump to 113.33.03 (diff)
downloadgentoo-cd29c7eeee749bca9c856baa462570632dee1934.tar.gz
gentoo-cd29c7eeee749bca9c856baa462570632dee1934.tar.bz2
gentoo-cd29c7eeee749bca9c856baa462570632dee1934.zip
dev-ml/js-build-tools: bump to 113.33.06
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/js-build-tools/js-build-tools-113.33.06.ebuild')
-rw-r--r--dev-ml/js-build-tools/js-build-tools-113.33.06.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/js-build-tools/js-build-tools-113.33.06.ebuild b/dev-ml/js-build-tools/js-build-tools-113.33.06.ebuild
new file mode 100644
index 000000000000..db4c32f92467
--- /dev/null
+++ b/dev-ml/js-build-tools/js-build-tools-113.33.06.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Collection of tools to help building Jane Street Packages"
+HOMEPAGE="https://github.com/janestreet/js-build-tools"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="dev-ml/ocamlbuild:="
+DEPEND="${RDEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc README.md
+}