summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-12 18:42:26 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-12 21:20:25 +0200
commit6d91438a6e3e80971bb42e8070a05a4726902399 (patch)
treeb297b217c2aa964cc75d2a054c67ff2c87c901fa /dev-ml/lambda-term/lambda-term-1.11.ebuild
parentdev-ml/lwt_ssl: initial import, split out of dev-ml/lwt (diff)
downloadgentoo-6d91438a6e3e80971bb42e8070a05a4726902399.tar.gz
gentoo-6d91438a6e3e80971bb42e8070a05a4726902399.tar.bz2
gentoo-6d91438a6e3e80971bb42e8070a05a4726902399.zip
dev-ml/lambda-term: bump to 1.11
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/lambda-term/lambda-term-1.11.ebuild')
-rw-r--r--dev-ml/lambda-term/lambda-term-1.11.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/lambda-term/lambda-term-1.11.ebuild b/dev-ml/lambda-term/lambda-term-1.11.ebuild
new file mode 100644
index 000000000000..7c744aea6219
--- /dev/null
+++ b/dev-ml/lambda-term/lambda-term-1.11.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A cross-platform library for manipulating the terminal"
+HOMEPAGE="https://github.com/diml/lambda-term"
+SRC_URI="https://github.com/diml/lambda-term/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/lwt_react:=
+ >=dev-ml/lwt-2.4.0:=
+ >=dev-ml/zed-1.2:=
+ >=dev-ml/react-1.2:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+"
+
+PATCHES=( "${FILESDIR}/lwtreact.patch" )
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --mandir="${ED}/usr/share/man" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}