summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-11-29 10:20:42 +0100
committerMichał Górny <mgorny@gentoo.org>2020-11-29 10:20:42 +0100
commit9e5389102aaa0806c6adfa9f8ff7b1ac1b5d1db1 (patch)
treedab5e939fbebbc5192aee5e1a6062669fd8ed11b /dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
parentsys-devel/clang: Resolve pkgcheck problems (diff)
downloadgentoo-9e5389102aaa0806c6adfa9f8ff7b1ac1b5d1db1.tar.gz
gentoo-9e5389102aaa0806c6adfa9f8ff7b1ac1b5d1db1.tar.bz2
gentoo-9e5389102aaa0806c6adfa9f8ff7b1ac1b5d1db1.zip
dev-ml/llvm-ocaml: Resolve pkgcheck problems
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
index 317ad24d0e20..1cc3103d9d2f 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-11.0.0.ebuild
@@ -17,7 +17,6 @@ ALL_LLVM_TARGETS=( AArch64 AMDGPU ARM AVR BPF Hexagon Lanai Mips MSP430
NVPTX PowerPC RISCV Sparc SystemZ WebAssembly X86 XCore
"${ALL_LLVM_EXPERIMENTAL_TARGETS[@]}" )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
-LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
SLOT="0/${PV}"
@@ -29,8 +28,14 @@ RESTRICT="!test? ( test )"
RDEPEND="
>=dev-lang/ocaml-4.00.0:0=
dev-ml/ocaml-ctypes:=
- ~sys-devel/llvm-${PV}:=[${LLVM_TARGET_USEDEPS// /,},debug?]
+ ~sys-devel/llvm-${PV}:=[debug?]
!sys-devel/llvm[ocaml(-)]"
+for x in "${ALL_LLVM_TARGETS[@]}"; do
+ RDEPEND+="
+ ~sys-devel/llvm-${PV}[${x}]"
+done
+unset x
+
DEPEND="${RDEPEND}"
BDEPEND="
dev-lang/perl