summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-27 10:35:02 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-27 14:26:54 +0200
commit23618ab1d7db68fba8b8350675cf1861653ba246 (patch)
tree8ce4b29c0f6e866760fac1ab7c350b281c4163bc /dev-ml/llvm-ocaml
parentsys-devel/llvmgold: Modernize (diff)
downloadgentoo-23618ab1d7db68fba8b8350675cf1861653ba246.tar.gz
gentoo-23618ab1d7db68fba8b8350675cf1861653ba246.tar.bz2
gentoo-23618ab1d7db68fba8b8350675cf1861653ba246.zip
dev-ml/llvm-ocaml: Modernize
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-15.0.0.9999.ebuild12
1 files changed, 8 insertions, 4 deletions
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-15.0.0.9999.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-15.0.0.9999.ebuild
index 9263abe8c53e..204608ff33a4 100644
--- a/dev-ml/llvm-ocaml/llvm-ocaml-15.0.0.9999.ebuild
+++ b/dev-ml/llvm-ocaml/llvm-ocaml-15.0.0.9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
PYTHON_COMPAT=( python3_{8..10} )
inherit cmake llvm llvm.org python-any-r1
@@ -19,14 +19,18 @@ RDEPEND="
>=dev-lang/ocaml-4.00.0:0=
dev-ml/ocaml-ctypes:=
~sys-devel/llvm-${PV}:=[debug?]
- !sys-devel/llvm[ocaml(-)]"
+ !sys-devel/llvm[ocaml(-)]
+"
-DEPEND="${RDEPEND}"
+DEPEND="
+ ${RDEPEND}
+"
BDEPEND="
+ ${PYTHON_DEPS}
dev-lang/perl
dev-ml/findlib
>=dev-util/cmake-3.16
- ${PYTHON_DEPS}"
+"
LLVM_COMPONENTS=( llvm cmake third-party )
LLVM_USE_TARGETS=llvm