summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-14 16:21:40 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-14 16:21:40 +0100
commit39f6ec11e3f7851fa8ba0700fddf97044b439c7b (patch)
tree6e3ba22655339877d8f426770b1fe03ec6c1d6f7 /dev-ml/llvm-ocaml
parentsys-devel/clang-common: Remove 14.0.0_rc2 (diff)
downloadgentoo-39f6ec11e3f7851fa8ba0700fddf97044b439c7b.tar.gz
gentoo-39f6ec11e3f7851fa8ba0700fddf97044b439c7b.tar.bz2
gentoo-39f6ec11e3f7851fa8ba0700fddf97044b439c7b.zip
dev-ml/llvm-ocaml: Remove 14.0.0_rc2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/llvm-ocaml')
-rw-r--r--dev-ml/llvm-ocaml/Manifest1
-rw-r--r--dev-ml/llvm-ocaml/llvm-ocaml-14.0.0_rc2.ebuild112
2 files changed, 0 insertions, 113 deletions
diff --git a/dev-ml/llvm-ocaml/Manifest b/dev-ml/llvm-ocaml/Manifest
index 13f80ba7cc93..7dd444fcb71f 100644
--- a/dev-ml/llvm-ocaml/Manifest
+++ b/dev-ml/llvm-ocaml/Manifest
@@ -2,5 +2,4 @@ DIST llvmorg-11.1.0.tar.gz 122776532 BLAKE2B ca842ff4afff8f44c82b5e7383962a9c45c
DIST llvmorg-12.0.1.tar.gz 134259748 BLAKE2B f41de787bc73ff2edfda1b22cc8602be6f65f37dd9e4c8888533cfa8c3ccdcf4f108aaab9de23ab0ab987966eb160f2a553a0bdff99461e71ddd5bfcd086090d SHA512 6eb0dc18e2c25935fabfdfc48b0114be0939158dfdef7b85b395fe2e71042672446af0e68750aae003c9847d10d1f63316fe95d3df738d18f249174292b1b9e1
DIST llvmorg-13.0.0.tar.gz 147270176 BLAKE2B 628f316b580e1edf3a58d4825b724df759e6ed2a4116802470c04562caefc392fa325c91f388036365a2e45a9595cca6d3557fab12984fc8bcfef29c9116d822 SHA512 8004c05d32b9720fb3391783621690c1df9bd1e97e72cbff9192ed88a84b0acd303b61432145fa917b5b5e548c8cee29b24ef8547dcc8677adf4816e7a8a0eb2
DIST llvmorg-13.0.1.tar.gz 147290251 BLAKE2B 2a44b012a672501761d0c27c6b3a315b69bfef0cd13b078a7e7d2fccc4a9c8c0f2bee0f164c4271c9106b0a99cb06e8b64986f66253b613336719fb86b82541b SHA512 9a8cb5d11964ba88b7624f19ec861fb28701f23956ea3c92f6ac644332d5f41fde97bd8933dd3ee70ed378058c252fa3a3887c8d1af90d219970c2b27691166f
-DIST llvmorg-14.0.0-rc2.tar.gz 158069989 BLAKE2B 06dcf5d82cd100bd792eadb3816cb297a11dc64dc8b699ccb2eac8ef0da4f10a24ba1984376427b638def6c8c8ae5bc9562e1cc30281fc55f044aa2a9657fc81 SHA512 c77d8c6db2ee6536f7e980465d5a3eb34403c6529e2012a4778ce76a559a6d639cf4c5ec84f965287d4b0739a73dc3e65d7deb27815d74c35e823839e579d2a3
DIST llvmorg-14.0.0-rc4.tar.gz 158082013 BLAKE2B 0e717898d8f1ed160e525a68aba56a84b7d31856ea72fdb8fa02e863c5a2074245a38d4a4aa7d178beab1ea64aa92d0ba9dcad4373ebb03868070bf718112107 SHA512 a942848aa5042b97bab6d0d5bcee11ea2f85f1244d7eaadb8f7000bf104b2160e6034c04e3755501dd178bc99c26669cf4aca40edb4bba598fdde6bcf3f40ddc
diff --git a/dev-ml/llvm-ocaml/llvm-ocaml-14.0.0_rc2.ebuild b/dev-ml/llvm-ocaml/llvm-ocaml-14.0.0_rc2.ebuild
deleted file mode 100644
index 45c941d6ddd7..000000000000
--- a/dev-ml/llvm-ocaml/llvm-ocaml-14.0.0_rc2.ebuild
+++ /dev/null
@@ -1,112 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit cmake llvm llvm.org python-any-r1
-
-DESCRIPTION="OCaml bindings for LLVM"
-HOMEPAGE="https://llvm.org/"
-
-LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
-SLOT="0/${PV}"
-KEYWORDS=""
-IUSE="debug test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-lang/ocaml-4.00.0:0=
- dev-ml/ocaml-ctypes:=
- ~sys-devel/llvm-${PV}:=[debug?]
- !sys-devel/llvm[ocaml(-)]"
-
-DEPEND="${RDEPEND}"
-BDEPEND="
- dev-lang/perl
- dev-ml/findlib
- >=dev-util/cmake-3.16
- test? ( dev-ml/ounit2 )
- ${PYTHON_DEPS}"
-
-LLVM_COMPONENTS=( llvm cmake third-party )
-LLVM_USE_TARGETS=llvm
-llvm.org_set_globals
-
-pkg_setup() {
- LLVM_MAX_SLOT=${PV%%.*} llvm_pkg_setup
- python-any-r1_pkg_setup
-}
-
-src_configure() {
- local libdir=$(get_libdir)
- local mycmakeargs=(
- -DLLVM_LIBDIR_SUFFIX=${libdir#lib}
-
- -DBUILD_SHARED_LIBS=OFF
- -DLLVM_BUILD_LLVM_DYLIB=ON
- -DLLVM_LINK_LLVM_DYLIB=ON
- -DLLVM_OCAML_OUT_OF_TREE=ON
-
- # cheap hack: LLVM combines both anyway, and the only difference
- # is that the former list is explicitly verified at cmake time
- -DLLVM_TARGETS_TO_BUILD=""
- -DLLVM_EXPERIMENTAL_TARGETS_TO_BUILD="${LLVM_TARGETS// /;}"
- -DLLVM_BUILD_TESTS=$(usex test)
-
- # disable various irrelevant deps and settings
- -DLLVM_ENABLE_FFI=OFF
- -DLLVM_ENABLE_TERMINFO=OFF
- -DHAVE_HISTEDIT_H=NO
- -DLLVM_ENABLE_ASSERTIONS=$(usex debug)
- -DLLVM_ENABLE_EH=ON
- -DLLVM_ENABLE_RTTI=ON
-
- -DLLVM_HOST_TRIPLE="${CHOST}"
-
- -DPython3_EXECUTABLE="${PYTHON}"
-
- # disable go bindings
- -DGO_EXECUTABLE=GO_EXECUTABLE-NOTFOUND
-
- # TODO: ocamldoc
- )
-
- use test && mycmakeargs+=(
- -DLLVM_LIT_ARGS="$(get_lit_flags)"
- )
-
- # LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
- # also: custom rules for OCaml do not work for CPPFLAGS
- use debug || local -x CFLAGS="${CFLAGS} -DNDEBUG"
- cmake_src_configure
-
- local llvm_libdir=$(llvm-config --libdir)
- # an ugly hack; TODO: figure out a way to pass -L to ocaml...
- cd "${BUILD_DIR}/${libdir}" || die
- ln -s "${llvm_libdir}"/*.so . || die
-
- if use test; then
- local llvm_bindir=$(llvm-config --bindir)
- # Force using system-installed tools.
- sed -i -e "/llvm_tools_dir/s@\".*\"@\"${llvm_bindir}\"@" \
- "${BUILD_DIR}"/test/lit.site.cfg.py || die
- fi
-}
-
-src_compile() {
- cmake_build ocaml_all
-}
-
-src_test() {
- # respect TMPDIR!
- local -x LIT_PRESERVES_TMP=1
- cmake_build check-llvm-bindings-ocaml
-}
-
-src_install() {
- DESTDIR="${D}" \
- cmake -P "${BUILD_DIR}"/bindings/ocaml/cmake_install.cmake || die
-
- dodoc bindings/ocaml/README.txt
-}