summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-22 11:10:55 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-22 11:10:55 +0100
commitbff1d5e742e490a65c75da96f9c80b7a7ef559fd (patch)
tree14eb959769855bd3acfc5c18a330ef9dd7fd4fd4 /dev-ml/macaque/macaque-0.7.4.ebuild
parentdev-ml/pgocaml: bump to 2.3 (diff)
downloadgentoo-bff1d5e742e490a65c75da96f9c80b7a7ef559fd.tar.gz
gentoo-bff1d5e742e490a65c75da96f9c80b7a7ef559fd.tar.bz2
gentoo-bff1d5e742e490a65c75da96f9c80b7a7ef559fd.zip
dev-ml/macaque: bump to 0.7.4
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/macaque/macaque-0.7.4.ebuild')
-rw-r--r--dev-ml/macaque/macaque-0.7.4.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-ml/macaque/macaque-0.7.4.ebuild b/dev-ml/macaque/macaque-0.7.4.ebuild
new file mode 100644
index 000000000000..19d2258ef8c6
--- /dev/null
+++ b/dev-ml/macaque/macaque-0.7.4.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit oasis
+
+DESCRIPTION="DSL for SQL Queries in Caml"
+HOMEPAGE="http://ocsigen.org/macaque/"
+SRC_URI="https://github.com/ocsigen/macaque/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND=">=dev-ml/pgocaml-2.1:=
+ dev-ml/camlp4:="
+RDEPEND="${DEPEND}"
+DOCS=( Changelog README.md )
+OASIS_SETUP_COMMAND="./setup.exe"
+
+src_configure() {
+ emake setup.exe
+ oasis_src_configure
+}