summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-26 19:50:20 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-26 20:34:01 +0200
commit69cf2321446c95170077aa8e914817419e236b5d (patch)
tree8cfa3878a41c25ebb95c2a0c42f79993279c6dd6 /dev-ml/mccs/mccs-1.1.2c.ebuild
parentx11-misc/ipager: EAPI 6 bump (diff)
downloadgentoo-69cf2321446c95170077aa8e914817419e236b5d.tar.gz
gentoo-69cf2321446c95170077aa8e914817419e236b5d.tar.bz2
gentoo-69cf2321446c95170077aa8e914817419e236b5d.zip
dev-ml/mccs: initial import
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-ml/mccs/mccs-1.1.2c.ebuild')
-rw-r--r--dev-ml/mccs/mccs-1.1.2c.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/mccs/mccs-1.1.2c.ebuild b/dev-ml/mccs/mccs-1.1.2c.ebuild
new file mode 100644
index 000000000000..3451a9f9423a
--- /dev/null
+++ b/dev-ml/mccs/mccs-1.1.2c.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit versionator opam
+
+MY_PV=$(replace_version_separator 2 '+')
+
+DESCRIPTION="Multi Criteria CUDF Solver"
+HOMEPAGE="http://www.i3s.unice.fr/~cpjm/misc/ https://github.com/AltGr/ocaml-mccs/issues"
+SRC_URI="https://github.com/AltGr/ocaml-mccs/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ dev-ml/cudf:=
+ sci-mathematics/glpk:=
+"
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder"
+
+S=${WORKDIR}/ocaml-${PN}-$(replace_version_separator 2 '-')
+
+src_compile() {
+ jbuilder build -p ${PN} || die
+}