summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-07-13 08:59:43 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-07-13 09:47:49 +0200
commit8717676e08dad1b756e6d547b13c29c23ca43fb4 (patch)
treef192db658f3082a394b47aad7f92c0a1e542205e /dev-ml/menhir/menhir-20170712.ebuild
parentdev-java/jmock: keyword ~arm64 (diff)
downloadgentoo-8717676e08dad1b756e6d547b13c29c23ca43fb4.tar.gz
gentoo-8717676e08dad1b756e6d547b13c29c23ca43fb4.tar.bz2
gentoo-8717676e08dad1b756e6d547b13c29c23ca43fb4.zip
dev-ml/menhir: bump to 20170712
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/menhir/menhir-20170712.ebuild')
-rw-r--r--dev-ml/menhir/menhir-20170712.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/menhir/menhir-20170712.ebuild b/dev-ml/menhir/menhir-20170712.ebuild
new file mode 100644
index 000000000000..5dfe716cd992
--- /dev/null
+++ b/dev-ml/menhir/menhir-20170712.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib eutils
+
+DESCRIPTION="LR(1) parser generator for the OCaml language"
+HOMEPAGE="http://gallium.inria.fr/~fpottier/menhir/"
+SRC_URI="http://gallium.inria.fr/~fpottier/menhir/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86"
+IUSE="examples +ocamlopt"
+
+RDEPEND=">=dev-lang/ocaml-4.02:=[ocamlopt?]"
+DEPEND="${RDEPEND}
+ dev-ml/ocamlbuild"
+
+src_configure() {
+ if ! use ocamlopt ; then
+ export TARGET=byte
+ fi
+}
+
+src_compile() {
+ emake PREFIX="${EPREFIX}"/usr -j1
+}
+
+src_install() {
+ findlib_src_preinst
+ emake PREFIX="${ED}"/usr docdir="${ED}"/usr/share/doc/"${PF}" $(use examples || echo "DOCS=manual.pdf") install
+ use examples && docompress -x /usr/share/doc/${PF}/demos
+ dodoc README.md CHANGES.md
+}