summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-06 22:20:53 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-08 22:25:48 +0200
commitf839dbde90cb4c7efaed2b599613fb830ba1b53b (patch)
tree454473b5910800f0fd0e392eba884bcd0e079028 /dev-ml/merlin/merlin-4.2-r2.ebuild
parentmedia-video/vidify-audiosync: pep517, enablepy3.11, EAPI8 (diff)
downloadgentoo-f839dbde90cb4c7efaed2b599613fb830ba1b53b.tar.gz
gentoo-f839dbde90cb4c7efaed2b599613fb830ba1b53b.tar.bz2
gentoo-f839dbde90cb4c7efaed2b599613fb830ba1b53b.zip
dev-ml/merlin: use <yojson-2
Bug: https://github.com/ocaml/merlin/pull/1475 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/merlin/merlin-4.2-r2.ebuild')
-rw-r--r--dev-ml/merlin/merlin-4.2-r2.ebuild83
1 files changed, 83 insertions, 0 deletions
diff --git a/dev-ml/merlin/merlin-4.2-r2.ebuild b/dev-ml/merlin/merlin-4.2-r2.ebuild
new file mode 100644
index 000000000000..ec4d4384818f
--- /dev/null
+++ b/dev-ml/merlin/merlin-4.2-r2.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# TODO: vim-plugin, although it's not clear how to make it work here
+inherit elisp-common dune
+
+DESCRIPTION="Context sensitive completion for OCaml in Vim and Emacs"
+HOMEPAGE="https://github.com/ocaml/merlin"
+SRC_URI="https://github.com/ocaml/merlin/archive/v${PV}-411.tar.gz -> ${P}-411.tar.gz
+ https://dev.gentoo.org/~tupone/distfiles/${P}-ocaml-4.12.patch.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="emacs +ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/csexp:=
+ <dev-ml/yojson-2:=
+ dev-ml/menhir:=
+ || (
+ dev-lang/ocaml:0/4.11
+ dev-lang/ocaml:0/4.12
+ )
+ emacs? (
+ >=app-editors/emacs-23.1:*
+ app-emacs/auto-complete
+ app-emacs/company-mode
+ )
+"
+DEPEND="${RDEPEND}
+ test? ( app-misc/jq )"
+
+SITEFILE="50${PN}-gentoo.el"
+
+S="${WORKDIR}"/${P}-411
+
+src_prepare() {
+ has_version "dev-lang/ocaml:0/4.12" && \
+ eapply "${WORKDIR}"/${P}-ocaml-4.12.patch
+ default
+
+ # Handle installation via the eclass
+ rm emacs/dune || die
+
+ # rm failing test
+ rm -r tests/test-dirs/locate/context-detection/cd-mod_constr.t || die
+}
+
+src_compile() {
+ dune build @install
+
+ if use emacs ; then
+ # Build the emacs integration
+ cd emacs || die
+
+ # iedit isn't packaged yet
+ rm merlin-iedit.el || die
+
+ elisp-compile *.el
+ fi
+}
+
+src_install() {
+ dune_src_install
+
+ if use emacs ; then
+ cd "${S}/emacs" || die
+ elisp-install ${PN} *.el *.elc
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}