summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2021-12-08 19:51:41 +0100
committerMaciej Barć <xgqt@gentoo.org>2021-12-08 19:52:33 +0100
commit71c2f844480f0917df0148a1e723a3dd62047037 (patch)
treeeef71459c6349a05a2c644b67e720d2dfe839907 /dev-ml/mew/mew-0.1.0-r1.ebuild
parentapp-admin/syslog-ng: Stabilize 3.34.1 arm64, #828343 (diff)
downloadgentoo-71c2f844480f0917df0148a1e723a3dd62047037.tar.gz
gentoo-71c2f844480f0917df0148a1e723a3dd62047037.tar.bz2
gentoo-71c2f844480f0917df0148a1e723a3dd62047037.zip
dev-ml/mew: add missing test depedndencies
Closes: https://bugs.gentoo.org/828560 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/mew/mew-0.1.0-r1.ebuild')
-rw-r--r--dev-ml/mew/mew-0.1.0-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/mew/mew-0.1.0-r1.ebuild b/dev-ml/mew/mew-0.1.0-r1.ebuild
new file mode 100644
index 000000000000..6298b8d0a721
--- /dev/null
+++ b/dev-ml/mew/mew-0.1.0-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="General modal editing engine generator"
+HOMEPAGE="https://github.com/kandu/mew"
+SRC_URI="https://github.com/kandu/mew/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/result:=
+ dev-ml/trie:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? ( dev-ml/ppx_expect )"