summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-07-24 00:58:47 +0100
committerSam James <sam@gentoo.org>2022-07-24 00:58:47 +0100
commit35dbc70751eeaf9503bb03fa15c8a967810711bd (patch)
tree99ecfc6a400f678dd265f8bce8e7d510760d0488 /dev-ml/mtime
parentdev-ml/dune-private-libs: drop 2.8.2-r1, 2.9.0 (diff)
downloadgentoo-35dbc70751eeaf9503bb03fa15c8a967810711bd.tar.gz
gentoo-35dbc70751eeaf9503bb03fa15c8a967810711bd.tar.bz2
gentoo-35dbc70751eeaf9503bb03fa15c8a967810711bd.zip
dev-ml/mtime: add 1.4.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/mtime')
-rw-r--r--dev-ml/mtime/Manifest1
-rw-r--r--dev-ml/mtime/mtime-1.4.0.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/mtime/Manifest b/dev-ml/mtime/Manifest
index 84c08ab65e6e..1c9a31f82d13 100644
--- a/dev-ml/mtime/Manifest
+++ b/dev-ml/mtime/Manifest
@@ -1,3 +1,4 @@
DIST mtime-1.1.0.tbz 15467 BLAKE2B 975fdb01c6a4806035a5fbc256d192d6c2f45bdfb750045293b10a732c5613108d9bce897d3c1be660af60d6e9bafbf299dedbc0d872d1c09f65f47b11c9a6b6 SHA512 8ed5dae589dd27fc6e748218a9d9fb9d7d954d231fc2100d61c1b336e0ed38a215bc608cdea9965547729177c78c868c1de6a5ceac6735686a3de1c4a791746c
DIST mtime-1.2.0.tbz 16272 BLAKE2B 317201f8d5e7a55636e58748ffd269db5e88aed012e8dd7ed269d1f128f8d21ed0e707679b030b9c822bac98c9b76033e8d2402171c4ee758d8c936fbeee7ee9 SHA512 0f0ed220cd0f899643930814010f8592e1f47b6dc6c4dce8eebfb17a81b0abed093a3dbf9c02490af99bf81ea640372f73b4ab88fd8ef0e0c7c66920692a8778
DIST mtime-1.3.0.tbz 17308 BLAKE2B f943ccb5d4c9ae28ae4620d1dbe897434d4d828091c8d0f17060a0fa40dde7fdcb73c6f85f7dd6fac8099d9608d6246613e2fc954bedb3d5b05b26149bd24260 SHA512 5b998ef803020de4771525adaa448623d348fa079800e72ba2ba78ff2d76a7d89da6200fe8bbc435d1355ad2c571c029398150d618912e58b5765fcf2210a5d0
+DIST mtime-1.4.0.tbz 15909 BLAKE2B 3c49deaf72d3873c8447f4a6d8ce89d55f3df60df108132ec078d81702a6fb9d532266efdf5290fe396d57a84de2d1912b48ad92f84db6d573d977492407b95b SHA512 0492fa5f5187b909fe2b0550363c7dcb8cffef963d51072272ef3d876b51e1ddf8de4c4e221cffb0144658fccf6a0dc584a5c8094a4b2208156e43bad5b269d4
diff --git a/dev-ml/mtime/mtime-1.4.0.ebuild b/dev-ml/mtime/mtime-1.4.0.ebuild
new file mode 100644
index 000000000000..c3bc91ca7fd8
--- /dev/null
+++ b/dev-ml/mtime/mtime-1.4.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit edo opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ edo ocaml pkg/pkg.ml build \
+ --tests $(usex test true false)
+}
+
+src_test() {
+ edo ocaml pkg/pkg.ml test
+}