summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-07-16 09:19:56 +0200
committerAlfredo Tupone <tupone@gentoo.org>2021-07-16 09:19:56 +0200
commit76cf489d83918b077242c46c8c4dd5ba243c7c7b (patch)
tree2e8ac0233924d119b0d49461721fe93175910257 /dev-ml/mtime
parentmedia-sound/abcm2ps: bump to 8.14.12 (diff)
downloadgentoo-76cf489d83918b077242c46c8c4dd5ba243c7c7b.tar.gz
gentoo-76cf489d83918b077242c46c8c4dd5ba243c7c7b.tar.bz2
gentoo-76cf489d83918b077242c46c8c4dd5ba243c7c7b.zip
dev-ml/mtime: bump 1.2.0
Package-Manager: Portage-3.0.20, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/mtime')
-rw-r--r--dev-ml/mtime/Manifest1
-rw-r--r--dev-ml/mtime/mtime-1.2.0.ebuild33
2 files changed, 34 insertions, 0 deletions
diff --git a/dev-ml/mtime/Manifest b/dev-ml/mtime/Manifest
index 5218f058d5c2..007cefadab62 100644
--- a/dev-ml/mtime/Manifest
+++ b/dev-ml/mtime/Manifest
@@ -1 +1,2 @@
DIST mtime-1.1.0.tbz 15467 BLAKE2B 975fdb01c6a4806035a5fbc256d192d6c2f45bdfb750045293b10a732c5613108d9bce897d3c1be660af60d6e9bafbf299dedbc0d872d1c09f65f47b11c9a6b6 SHA512 8ed5dae589dd27fc6e748218a9d9fb9d7d954d231fc2100d61c1b336e0ed38a215bc608cdea9965547729177c78c868c1de6a5ceac6735686a3de1c4a791746c
+DIST mtime-1.2.0.tbz 16272 BLAKE2B 317201f8d5e7a55636e58748ffd269db5e88aed012e8dd7ed269d1f128f8d21ed0e707679b030b9c822bac98c9b76033e8d2402171c4ee758d8c936fbeee7ee9 SHA512 0f0ed220cd0f899643930814010f8592e1f47b6dc6c4dce8eebfb17a81b0abed093a3dbf9c02490af99bf81ea640372f73b4ab88fd8ef0e0c7c66920692a8778
diff --git a/dev-ml/mtime/mtime-1.2.0.ebuild b/dev-ml/mtime/mtime-1.2.0.ebuild
new file mode 100644
index 000000000000..a6d491ea6add
--- /dev/null
+++ b/dev-ml/mtime/mtime-1.2.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam
+
+DESCRIPTION="OCaml module to access monotonic wall-clock time"
+HOMEPAGE="https://erratique.ch/software/mtime https://github.com/dbuenzli/mtime"
+SRC_URI="https://erratique.ch/software/mtime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-lang/ocaml:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ dev-ml/topkg
+ dev-ml/ocamlbuild
+ dev-ml/findlib"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --with-js_of_ocaml false \
+ --tests $(usex test true false) \
+ || die
+}
+
+src_test() {
+ ocaml pkg/pkg.ml test || die
+}