summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-03-01 19:29:49 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-03-01 19:47:37 +0100
commit4c69b95d02ad9ddd54cbe478b95082f52f251933 (patch)
tree6e98e551764ffa81eff0f88fc749158d2d49d72f /dev-ml/oasis/oasis-0.4.5-r1.ebuild
parentdev-ml/parmap: add ocamlbuild dep (diff)
downloadgentoo-4c69b95d02ad9ddd54cbe478b95082f52f251933.tar.gz
gentoo-4c69b95d02ad9ddd54cbe478b95082f52f251933.tar.bz2
gentoo-4c69b95d02ad9ddd54cbe478b95082f52f251933.zip
dev-ml/oasis: add rdepend on ocamlbuild
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/oasis/oasis-0.4.5-r1.ebuild')
-rw-r--r--dev-ml/oasis/oasis-0.4.5-r1.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-ml/oasis/oasis-0.4.5-r1.ebuild b/dev-ml/oasis/oasis-0.4.5-r1.ebuild
new file mode 100644
index 000000000000..a0b11745ba3a
--- /dev/null
+++ b/dev-ml/oasis/oasis-0.4.5-r1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+MY_P=${P/_/\~}
+DESCRIPTION="OASIS is a tool to integrate a configure, build and install system in OCaml project"
+HOMEPAGE="http://oasis.forge.ocamlcore.org/index.php"
+SRC_URI="http://forge.ocamlcore.org/frs/download.php/1475/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=">=dev-ml/ocaml-data-notation-0.0.11:=
+ dev-ml/ocamlbuild:=[ocamlopt]"
+DEPEND="${RDEPEND}
+ >=dev-ml/findlib-1.3.1
+ dev-ml/ocamlify
+ dev-ml/ocamlmod
+ !<sci-chemistry/oasis-4.0-r3
+ test? (
+ >=dev-ml/ocaml-fileutils-0.4.2
+ >=dev-ml/ounit-2.0.0
+ >=dev-ml/ocaml-expect-0.0.4
+ dev-ml/pcre-ocaml
+ dev-ml/extlib
+ )"
+
+STRIP_MASK="*/bin/*"
+S="${WORKDIR}/${MY_P}"
+DOCS=( "README.txt" "TODO.txt" "AUTHORS.txt" "CHANGES.txt" )