summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-06-20 23:33:07 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-06-20 23:33:07 +0200
commit977740476eab8e4b9c431f87d423002677abcd6d (patch)
tree79691356ea80040e32891c51218ede23cb1c126b /dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild
parentdev-ml/bos: initial import (diff)
downloadgentoo-977740476eab8e4b9c431f87d423002677abcd6d.tar.gz
gentoo-977740476eab8e4b9c431f87d423002677abcd6d.tar.bz2
gentoo-977740476eab8e4b9c431f87d423002677abcd6d.zip
dev-ml/ocaml-base64: bump to 2.2.0
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild')
-rw-r--r--dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild b/dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild
new file mode 100644
index 000000000000..722eba386ee9
--- /dev/null
+++ b/dev-ml/ocaml-base64/ocaml-base64-2.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit findlib
+
+DESCRIPTION="Library for radix-64 representation (de)coding"
+HOMEPAGE="https://github.com/mirage/ocaml-base64"
+SRC_URI="https://github.com/mirage/ocaml-base64/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-lang/ocaml-4.02:="
+DEPEND="${RDEPEND}
+ dev-ml/jbuilder
+ dev-ml/opam
+ test? ( dev-ml/rresult dev-ml/bos dev-ml/alcotest )
+"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ base64.install || die
+}