summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 15:18:53 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-01 15:25:27 +0200
commitc0509acd103d992bca60f80b05e20c8b980ea516 (patch)
tree26c97c80c13fc91ce2d83d75d54e304995eab9db /dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
parentx11-wm/mutter: amd64 stable wrt bug #611134 (diff)
downloadgentoo-c0509acd103d992bca60f80b05e20c8b980ea516.tar.gz
gentoo-c0509acd103d992bca60f80b05e20c8b980ea516.tar.bz2
gentoo-c0509acd103d992bca60f80b05e20c8b980ea516.zip
dev-ml/ocaml-compiler-libs: Initial import. Ebuild by me.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild')
-rw-r--r--dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
new file mode 100644
index 000000000000..a7eb91fb1ad3
--- /dev/null
+++ b/dev-ml/ocaml-compiler-libs/ocaml-compiler-libs-0.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Repackage the OCaml compiler libraries so they do not expose everything at toplevel"
+HOMEPAGE="https://github.com/janestreet/ocaml-compiler-libs"
+SRC_URI="https://github.com/janestreet/ocaml-compiler-libs/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-lang/ocaml:="
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/opam
+ dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ --mandir="${ED}/usr/share/man" \
+ ${PN}.install || die
+}