summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-10-13 09:39:13 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-10-13 10:05:52 +0200
commit143ffd9d2d3dc5b0ba52baeec4e08ee13046a955 (patch)
treee8707c953b355fe61ee3edc07d6348d49f548db4 /dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
parentdev-ml/ocaml-containers: Remove old (diff)
downloadgentoo-143ffd9d2d3dc5b0ba52baeec4e08ee13046a955.tar.gz
gentoo-143ffd9d2d3dc5b0ba52baeec4e08ee13046a955.tar.bz2
gentoo-143ffd9d2d3dc5b0ba52baeec4e08ee13046a955.zip
dev-ml/ocaml-containers: bump to 1.4
Package-Manager: Portage-2.3.11, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild')
-rw-r--r--dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild b/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
new file mode 100644
index 000000000000..33e8871a4f73
--- /dev/null
+++ b/dev-ml/ocaml-containers/ocaml-containers-1.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="A modular standard library focused on data structures"
+HOMEPAGE="https://github.com/c-cube/ocaml-containers"
+SRC_URI="https://github.com/c-cube/ocaml-containers/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-ml/result:=
+ >=dev-ml/sequence-0.9:=
+"
+DEPEND="${RDEPEND} dev-ml/cppo
+ test? ( dev-ml/iTeML dev-ml/ounit dev-ml/gen )"
+
+src_configure() {
+ oasis_configure_opts="
+ --enable-unix
+ --disable-bench
+ " oasis_src_configure
+}