summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-06 15:20:50 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-06 15:26:04 +0200
commit7a65def575aea9ebe28beb37929eff4f6afba181 (patch)
tree8af19731b4aa45c698910c49c5de1e88ad982f91 /dev-ml/ocaml-cstruct/ocaml-cstruct-2.1.0.ebuild
parentdev-ml/ocaml-dns: bump to 0.18.1 (diff)
downloadgentoo-7a65def575aea9ebe28beb37929eff4f6afba181.tar.gz
gentoo-7a65def575aea9ebe28beb37929eff4f6afba181.tar.bz2
gentoo-7a65def575aea9ebe28beb37929eff4f6afba181.zip
dev-ml/ocaml-cstruct: bump to 2.1.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-ml/ocaml-cstruct/ocaml-cstruct-2.1.0.ebuild')
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-2.1.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-2.1.0.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.1.0.ebuild
new file mode 100644
index 000000000000..7c5d31d8d73b
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.1.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )