summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-08-18 13:02:39 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-08-18 13:02:39 +0200
commit265fe0042cff96226d486ccf3ed5c04f944c2840 (patch)
tree0769aeda5caa56501937d4043c0fc09b0bcfd1a4 /dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.0.ebuild
parentapp-vim/bnf-syntax: EAPI 6 bump. (diff)
downloadgentoo-265fe0042cff96226d486ccf3ed5c04f944c2840.tar.gz
gentoo-265fe0042cff96226d486ccf3ed5c04f944c2840.tar.bz2
gentoo-265fe0042cff96226d486ccf3ed5c04f944c2840.zip
dev-ml/ocaml-cstruct: bump to 2.3.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.0.ebuild')
-rw-r--r--dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.0.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.0.ebuild b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.0.ebuild
new file mode 100644
index 000000000000..ec1f10ab6940
--- /dev/null
+++ b/dev-ml/ocaml-cstruct/ocaml-cstruct-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="Map OCaml arrays onto C-like structs"
+HOMEPAGE="https://github.com/mirage/ocaml-cstruct https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ppx"
+
+RDEPEND="
+ async? ( dev-ml/async:= )
+ lwt? ( dev-ml/lwt:= )
+ ppx? ( dev-ml/ppx_tools:= )
+ >=dev-lang/ocaml-4.01:=
+ dev-ml/ocplib-endian:=
+ dev-ml/sexplib:=
+ dev-ml/type-conv:=
+"
+DEPEND="
+ test? ( dev-ml/ounit )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable lwt)
+ $(use_enable async)
+ $(use_enable ppx)
+ --enable-unix
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )