summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-01-30 13:39:13 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-01-30 23:21:57 +0100
commit4cf640a8b699c46adb3900a858ae7fe517421a8f (patch)
treeb6000a591468aeeb7b4cd434337d4a32395fd0a6 /dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild
parentmedia-libs/gd: Security bump to version 2.2.4 (bug #607718). (diff)
downloadgentoo-4cf640a8.tar.gz
gentoo-4cf640a8.tar.bz2
gentoo-4cf640a8.zip
dev-ml/ocaml-ctypes: bump to 0.11.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild
new file mode 100644
index 000000000000..b94a5aa2bc8c
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.11.3.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ virtual/libffi
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}