summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 23:16:53 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:49 +1100
commit4b9a416b5676589fd8a65c2a28d7bc04687f6ed0 (patch)
treea51e813e64c7d141b5e5081590d73a1789035db1 /dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild
parentdev-ml/ocaml-migrate-parsetree: Bump to 2.0.0 (diff)
downloadgentoo-4b9a416b5676589fd8a65c2a28d7bc04687f6ed0.tar.gz
gentoo-4b9a416b5676589fd8a65c2a28d7bc04687f6ed0.tar.bz2
gentoo-4b9a416b5676589fd8a65c2a28d7bc04687f6ed0.zip
dev-ml/ocaml-ctypes: Bump to 0.17.2
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild')
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild
new file mode 100644
index 000000000000..5370c08eb051
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.17.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ >=dev-libs/libffi-3.3_rc0:0/7
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}