summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-27 18:30:06 +0100
committerSam James <sam@gentoo.org>2021-07-27 18:30:48 +0100
commit9e37e39ce399cb099f23aeb64e8fc626b263bb47 (patch)
treeabad62f88d8bb6a459cb792e6f03cba90994bfda /dev-ml/ocaml-ctypes
parentdev-ml/ocaml-ctypes: unrestrict libffi subslot (diff)
downloadgentoo-9e37e39ce399cb099f23aeb64e8fc626b263bb47.tar.gz
gentoo-9e37e39ce399cb099f23aeb64e8fc626b263bb47.tar.bz2
gentoo-9e37e39ce399cb099f23aeb64e8fc626b263bb47.zip
dev-ml/ocaml-ctypes: add 0.19.1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/Manifest1
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ctypes/Manifest b/dev-ml/ocaml-ctypes/Manifest
index 73f0a2b679da..d36f7d612cd4 100644
--- a/dev-ml/ocaml-ctypes/Manifest
+++ b/dev-ml/ocaml-ctypes/Manifest
@@ -1 +1,2 @@
DIST ocaml-ctypes-0.17.1.tar.gz 208101 BLAKE2B b9fe6632058a670c988ba9f1ae81b75aa5373de7231cef04d5e2ede61a44cbaa0324c04197a0a202847599a9bbe7dccd18fd3279f3f351493aaec4959caf3ada SHA512 1e197009f7e6b29b43944f757e987934337ebfa11bb2ff2ca8ba3ebc607e37cf1259d07a90d7faf4b91b49ee20d5c65357ad305f34ada0a8d336a3904233150e
+DIST ocaml-ctypes-0.19.1.tar.gz 206762 BLAKE2B 29b4636e711b9b3ecf3de5d66b796d4d8ddf1109fd7b065666577ce9412e0ef3712f704729dac3b9467ac7ace8f501b90bfc1dc82b86dbe1668e5d13be46741f SHA512 cbf422a2c457b215815a04122d0522ed0f274c5927cecd25951472de6cc6fcd1151b67f95d6bbfeeb3b5f15a9fe9bdedb8861e77bd0de9902418962065e4dfc0
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild
new file mode 100644
index 000000000000..40a1bee9e11b
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.19.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="Library for binding to C libraries using pure OCaml"
+HOMEPAGE="https://github.com/ocamllabs/ocaml-ctypes"
+SRC_URI="https://github.com/ocamllabs/ocaml-ctypes/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lang/ocaml-4.02:=[ocamlopt]
+ >=dev-libs/libffi-3.3_rc0:=
+ dev-ml/bigarray-compat:=
+ dev-ml/integers:=
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit2 dev-ml/lwt )"
+
+src_prepare() {
+ sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die
+ default
+}
+
+src_compile() {
+ emake -j1
+}
+
+src_test() {
+ emake -j1 test
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.md README.md
+}