summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-03-06 14:07:19 +0100
committerAlexis Ballier <aballier@gentoo.org>2017-03-06 14:19:52 +0100
commit3c9d1a719a1f627b6f3617bc1295a9c58b7a04be (patch)
tree96f53618af77fff5493d0d9804c4f0f4cdfd79bb /dev-ml/ocaml-dns
parentapp-forensics/volatility: version bump, allow building against pycryptodome (diff)
downloadgentoo-3c9d1a719a1f627b6f3617bc1295a9c58b7a04be.tar.gz
gentoo-3c9d1a719a1f627b6f3617bc1295a9c58b7a04be.tar.bz2
gentoo-3c9d1a719a1f627b6f3617bc1295a9c58b7a04be.zip
dev-ml/ocaml-dns: Bump to 0.19.1
Package-Manager: Portage-2.3.4, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ocaml-dns')
-rw-r--r--dev-ml/ocaml-dns/Manifest1
-rw-r--r--dev-ml/ocaml-dns/ocaml-dns-0.19.1.ebuild61
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dns/Manifest b/dev-ml/ocaml-dns/Manifest
index 6ed5fd3b08eb..a7d753448639 100644
--- a/dev-ml/ocaml-dns/Manifest
+++ b/dev-ml/ocaml-dns/Manifest
@@ -1,2 +1,3 @@
DIST ocaml-dns-0.18.1.tar.gz 144857 SHA256 c570a9f215bbafacb83319fd1d21fd393357c97359c237b941767d81764cc5e6 SHA512 909e7de8b434769aee04c4837cbcecd2856ad11b863f061eca650621b0caab81327107b58ecf20d65270f36b192d438baa3868b906cd9243163b2c697bf68684 WHIRLPOOL 043200a93926bc67859e6ff6f03ecfc1184ad3e13595fa71891a9e8ba3932ab2d3e46f32a145b11989d185e519548693af605b617ce7914dda1711d40a2d2d88
DIST ocaml-dns-0.19.0.tar.gz 150398 SHA256 d9591f8cc3498667e66683251e68e3e32ff3c1f7cc7cf36d945c2706f96854fd SHA512 3b885bb202bd32b9a9961e3f971fe8c404b7585f27214076c09a0c524a8f382d1f584843237169b51e209dee401a630f6240c3789ac1d2d6980e15feb3e508df WHIRLPOOL 100215eb9c8ab867056eb849917d96408380cc9f9a1447b1f29c6fae03a0ed44c6e74fb461bee8f54f7f521ff5ab7270c7eb38ef0685a6010bdba17903eaf400
+DIST ocaml-dns-0.19.1.tar.gz 99433 SHA256 6356939529548b979c350d1323971bc9a2aa5b937d4d57412dbd8ef1f87d1c3e SHA512 6866d38b64be1b19ccadc8e0c199b89f08db42ecfcb65d0e0a714f00a4a712cc84dcb334730bd385f1073fd1abd2ae124d96374bb3e85ed2d8642427feedd1ad WHIRLPOOL ff187af0d53b4747840a2c6ca924fc498aff0d6342aace856c878eef56c870903f9a8b3d84982bdbca2455579d2714b9f8784f024836078abc9dc7e1da01f65d
diff --git a/dev-ml/ocaml-dns/ocaml-dns-0.19.1.ebuild b/dev-ml/ocaml-dns/ocaml-dns-0.19.1.ebuild
new file mode 100644
index 000000000000..870e444c2569
--- /dev/null
+++ b/dev-ml/ocaml-dns/ocaml-dns-0.19.1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit findlib
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt +ocamlopt test"
+
+RDEPEND="
+ async? ( >=dev-ml/async-112.24.00:= )
+ lwt? ( >=dev-ml/lwt-2.4.7:=
+ dev-ml/ocaml-cstruct:=[lwt(-)] )
+ >=dev-lang/ocaml-4:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-1.9.0:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ dev-ml/ocaml-hashcons:=[ocamlopt?]
+ dev-lang/ocaml:=[ocamlopt?]
+ !<dev-ml/mirage-types-1.2.0
+ !dev-ml/odns
+"
+DEPEND="
+ test? (
+ dev-ml/ounit
+ dev-ml/ocaml-pcap
+ )
+ dev-ml/topkg
+ dev-ml/ppx_tools
+ ${RDEPEND}
+"
+# Missing mirage deps
+RESTRICT="test"
+
+src_compile() {
+ ocaml pkg/pkg.ml build \
+ --tests $(usex test true false) \
+ --with-lwt $(usex lwt true false) \
+ --with-async $(usex async true false) \
+ || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ dns.install || die
+ dodoc CHANGES.md README.md TODO.md
+}