summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Brewer <tomboy64@sina.cn>2015-10-16 14:06:35 +0200
committerMatthew Brewer <tomboy64@sina.cn>2015-10-18 13:42:51 +0200
commitc020237dca6bf3513af8919d75dfd4591dc875a1 (patch)
treebe96d07e4cd8ea94b49e6957d576ce5b9acfefa2 /dev-ml/ocaml-dns
parentdev-ml/mirage-profile: Add link to upstream bug report for test failures. (diff)
downloadgentoo-c020237dca6bf3513af8919d75dfd4591dc875a1.tar.gz
gentoo-c020237dca6bf3513af8919d75dfd4591dc875a1.tar.bz2
gentoo-c020237dca6bf3513af8919d75dfd4591dc875a1.zip
dev-ml/ocaml-dns: new ebuild
- ocaml-dns clashes with ancient odns and apparently supersedes it - explicit support for MirageOS is not enabled
Diffstat (limited to 'dev-ml/ocaml-dns')
-rw-r--r--dev-ml/ocaml-dns/Manifest1
-rw-r--r--dev-ml/ocaml-dns/metadata.xml13
-rw-r--r--dev-ml/ocaml-dns/ocaml-dns-0.15.3.ebuild49
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-ml/ocaml-dns/Manifest b/dev-ml/ocaml-dns/Manifest
new file mode 100644
index 000000000000..01f2a439d1b9
--- /dev/null
+++ b/dev-ml/ocaml-dns/Manifest
@@ -0,0 +1 @@
+DIST ocaml-dns-0.15.3.tar.gz 143042 SHA256 cc1361e51d1a7b6fa8d552dc06cad09288ba00e78a9ddcd5a0e49ab3d12a9619 SHA512 7176e93a263975d31a6757acf01ac5be10eb34b19a2c3a5d5e92b087a574e76db16861923162ad73833379dc5132868d0b91e1f2ed692e2bdff5667938a76db6 WHIRLPOOL 9b282ffdaf9fd834d449e33176fb9e5a231e6a7f2a1a12b0da4825a96f820b3f87a73c9e4751c19bbf80c9b8ab2f30c1730003b010bd6153b83bb9009334986d
diff --git a/dev-ml/ocaml-dns/metadata.xml b/dev-ml/ocaml-dns/metadata.xml
new file mode 100644
index 000000000000..d639c50aaf16
--- /dev/null
+++ b/dev-ml/ocaml-dns/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>ml</herd>
+ <herd>proxy-maintainers</herd>
+ <maintainer>
+ <email>tomboy64@sina.cn</email>
+ </maintainer>
+ <use>
+ <flag name="async">support for asynchronous execution</flag>
+ <flag name="lwt">enable threads via lwt</flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/ocaml-dns/ocaml-dns-0.15.3.ebuild b/dev-ml/ocaml-dns/ocaml-dns-0.15.3.ebuild
new file mode 100644
index 000000000000..bf1a7813ec71
--- /dev/null
+++ b/dev-ml/ocaml-dns/ocaml-dns-0.15.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_DOCS=1
+OASIS_BUILD_TESTS=1
+
+inherit oasis
+
+DESCRIPTION="A pure OCaml implementation of the DNS protocol"
+HOMEPAGE="https://github.com/mirage/ocaml-dns https://mirage.io"
+SRC_URI="https://github.com/mirage/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2 LGPL-2.1-with-linking-exception ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="async +lwt"
+
+RDEPEND="
+ async? ( >=dev-ml/async-112.24.00:= )
+ lwt? ( >=dev-ml/lwt-2.4.7:=
+ dev-ml/ocaml-cstruct:=[lwt(-)] )
+ >=dev-lang/ocaml-4:=
+ dev-ml/cmdliner:=
+ dev-ml/mirage-profile:=
+ >=dev-ml/ocaml-base64-2.0.0:=
+ >=dev-ml/ocaml-cstruct-1.0.1:=
+ >=dev-ml/ocaml-ipaddr-2.6.0:=
+ dev-ml/ocaml-re:=
+ >=dev-ml/ocaml-uri-1.7.0:=
+ !<dev-ml/mirage-types-1.2.0
+ !dev-ml/odns
+"
+DEPEND="
+ test? ( dev-ml/ounit
+ dev-ml/ocaml-pcap )
+ ${RDEPEND}
+"
+
+src_configure() {
+ oasis_configure_opts="
+ $(use_enable async)
+ $(use_enable lwt)
+ $(use_enable test nettests)
+ " oasis_src_configure
+}
+
+DOCS=( CHANGES README.md TODO.md )