summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-07-18 15:19:37 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-07-18 15:20:44 +0200
commitd7b67e4599fe77bba99487e856272c8b89e13113 (patch)
tree9bb938ae1a1e7be7c6b38a2bb48691da150908cc /dev-ml/ocaml-redis/ocaml-redis-0.3.1.ebuild
parentdev-ml/ocaml-redis: remove old (diff)
downloadgentoo-d7b67e4599fe77bba99487e856272c8b89e13113.tar.gz
gentoo-d7b67e4599fe77bba99487e856272c8b89e13113.tar.bz2
gentoo-d7b67e4599fe77bba99487e856272c8b89e13113.zip
dev-ml/ocaml-redis: bump to 0.3.1
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ocaml-redis/ocaml-redis-0.3.1.ebuild')
-rw-r--r--dev-ml/ocaml-redis/ocaml-redis-0.3.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ocaml-redis/ocaml-redis-0.3.1.ebuild b/dev-ml/ocaml-redis/ocaml-redis-0.3.1.ebuild
new file mode 100644
index 000000000000..7f07088fca6a
--- /dev/null
+++ b/dev-ml/ocaml-redis/ocaml-redis-0.3.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+OASIS_BUILD_TESTS=1
+OASIS_BUILD_DOCS=1
+
+inherit oasis
+
+DESCRIPTION="Redis bindings for OCaml"
+HOMEPAGE="http://0xffea.github.io/ocaml-redis/"
+SRC_URI="https://github.com/0xffea/ocaml-redis/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+lwt"
+
+RDEPEND="
+ dev-ml/ocaml-re:=
+ dev-ml/uuidm:=
+ lwt? ( dev-ml/lwt:= )
+"
+DEPEND="${RDEPEND}
+ test? ( dev-ml/ounit )"
+
+src_configure() {
+ oasis_configure_opts="$(use_enable lwt)" oasis_src_configure
+}