summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-07-12 19:26:25 -0600
committerChristoph Junghans <junghans@gentoo.org>2022-07-12 19:26:25 -0600
commit83689e263e4b00dcf7b78603044d660fb91a5422 (patch)
tree066b1e67a1bd9d6f4c6640c5abacefce60881907 /dev-ml/ocamlfuse
parentdev-ml/gapi-ocaml: initial commit (diff)
downloadgentoo-83689e263e4b00dcf7b78603044d660fb91a5422.tar.gz
gentoo-83689e263e4b00dcf7b78603044d660fb91a5422.tar.bz2
gentoo-83689e263e4b00dcf7b78603044d660fb91a5422.zip
dev-ml/ocamlfuse: initial commit
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-ml/ocamlfuse')
-rw-r--r--dev-ml/ocamlfuse/Manifest1
-rw-r--r--dev-ml/ocamlfuse/metadata.xml23
-rw-r--r--dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild37
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-ml/ocamlfuse/Manifest b/dev-ml/ocamlfuse/Manifest
new file mode 100644
index 000000000000..3a0975208f94
--- /dev/null
+++ b/dev-ml/ocamlfuse/Manifest
@@ -0,0 +1 @@
+DIST ocamlfuse-2.7.1_p7-r1.tar.gz 21469 BLAKE2B fa587d19124c2e2d320091bb42b098644d3112e39652dbf621c88f701effdab0ce15372b6f2461709eb3afe628e2888db3a7a0c9abeab8b8a136d09c69c84ac4 SHA512 342a6ce8a81ac05d47d4458ef6e9aa750e4e7643a89d28705664852f0549e1932643e8db5d93225ba496611654b3f11fef6aca1e6e40e8d4b30064fc9c65f7fd
diff --git a/dev-ml/ocamlfuse/metadata.xml b/dev-ml/ocamlfuse/metadata.xml
new file mode 100644
index 000000000000..c4853a8f842c
--- /dev/null
+++ b/dev-ml/ocamlfuse/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">This is a binding to FUSE for the OCaml programming language, enabling
+you to write multithreaded filesystems in the OCaml language. It has
+been designed with simplicity as a goal, as you can see by looking at
+example/fusexmp.ml. Efficiency has also been a separate goal. The
+Bigarray library is used for read and writes, allowing the library to
+do zero-copy in OCaml land.</longdescription>
+ <upstream>
+ <bugs-to>https://github.com/astrada/ocamlfuse/issues</bugs-to>
+ <remote-id type="github">astrada/ocamlfuse</remote-id>
+ <remote-id type="sourceforge">ocamlfuse</remote-id>
+ <maintainer>
+ <name>Alessandro Strada</name>
+ <email>alessandro.strada@gmail.com</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
new file mode 100644
index 000000000000..fdf08ccbc300
--- /dev/null
+++ b/dev-ml/ocamlfuse/ocamlfuse-2.7.1_p7-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune toolchain-funcs
+
+MYPV="${PV/_p/_cvs}"
+
+DESCRIPTION="OCaml binding for fuse"
+HOMEPAGE="
+ https://sourceforge.net/projects/ocamlfuse/
+ https://github.com/astrada/ocamlfuse
+ https://opam.ocaml.org/packages/ocamlfuse
+"
+SRC_URI="https://github.com/astrada/${PN}/archive/v${MYPV}.tar.gz -> ${PF}.tar.gz"
+S="${WORKDIR}/${PN}-${MYPV}"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="ocamlopt"
+
+RDEPEND="
+ dev-ml/camlidl:=
+ sys-fs/fuse:0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-ml/dune-configurator
+ dev-ml/opam
+"
+
+src_compile() {
+ tc-export CPP
+ dune_src_compile
+}