summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-15 07:36:15 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-15 07:36:58 +0200
commit8e342393434928ed5bcf9e38207a4ce12d365a28 (patch)
tree4c0b6180ab4fd20602e5044c71201388ce333bdc /dev-ml/ocamlnet
parentdev-ml/ocaml-migrate-parsetree: Remove old (diff)
downloadgentoo-8e342393434928ed5bcf9e38207a4ce12d365a28.tar.gz
gentoo-8e342393434928ed5bcf9e38207a4ce12d365a28.tar.bz2
gentoo-8e342393434928ed5bcf9e38207a4ce12d365a28.zip
dev-ml/ocamlnet: bump to 4.1.4
Package-Manager: Portage-2.3.7, Repoman-2.3.3
Diffstat (limited to 'dev-ml/ocamlnet')
-rw-r--r--dev-ml/ocamlnet/Manifest1
-rw-r--r--dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-ml/ocamlnet/Manifest b/dev-ml/ocamlnet/Manifest
index ea8cb71ea583..c3c2d91e94d4 100644
--- a/dev-ml/ocamlnet/Manifest
+++ b/dev-ml/ocamlnet/Manifest
@@ -1,2 +1,3 @@
DIST ocamlnet-4.1.2.tar.gz 4623183 SHA256 918c3921529cfe545e206b3535a58f43f665165044dd3548f685b583e94f14d8 SHA512 69f42042a54efd662db2217224da53513fc7e72c7b2313d4a4a1128f1b4624f4f6298434f5b19f354b832119ff151abc81e85eb0108d6eb24f30f82d176e0b4d WHIRLPOOL 27e1a8eb24361cadb8b2fb2b61bc6e93d71be8290873ca5bb1eebe16b9c9b1db69eae3b20c8deb3f6656aa79171a817b15acae53159d80ff8f4c946c201de173
DIST ocamlnet-4.1.3.tar.gz 4553037 SHA256 8a01393ed26c5475bba89aab928e9aa8a366af1e810416d9c916265a7f1cd5c5 SHA512 683ab6f529639c9da01478ba8ba7a1bf89a418ad3872331bb3e29067c0a75ddc0db996630ce5a5dd116967d6e3e756ade02d9a78b865bbc226f95d01af9e3956 WHIRLPOOL 56f2772ea02bbf9c3166d13797083cabc8a8dad8f8c53be7796361383f7c9ff9406e0d273d402a2415b3f5437b163977ad7f5a1bfccb46994de552dd4ebd1acb
+DIST ocamlnet-4.1.4.tar.gz 4552969 SHA256 46c3dace26123bdded9fd5ee841a18ede47d4b940e9320ce1db168d5891e1142 SHA512 ca502444f81898ccda27d61760a357aad59624cf3c4c025d49dd1c2e7bc3ef497c199634247ba7731e016c234e5cd92d2599d1ef9ecd55c3b6e7a64fc4773ee0 WHIRLPOOL aab363eaae3528f792218ec360a4dbf927984e6bd85d4bf5eb6292f64da035b6ed67957a43ef8df62208425cbafe4582b65c07e150600db591f76f9483bd46ff
diff --git a/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild b/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
new file mode 100644
index 000000000000..1460d03f5cc4
--- /dev/null
+++ b/dev-ml/ocamlnet/ocamlnet-4.1.4.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="5"
+
+inherit eutils findlib
+
+MY_P=${P/_beta/test}
+DESCRIPTION="Modules for OCaml application-level Internet protocols"
+HOMEPAGE="http://projects.camlcity.org/projects/ocamlnet.html"
+SRC_URI="http://download.camlcity.org/download/${MY_P}.tar.gz"
+
+LICENSE="ZLIB GPL-2+"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk kerberos tk httpd +ocamlopt +pcre ssl zip"
+RESTRICT="installsources"
+
+# the auth-dh compile flag has been disabled as well, since it depends on
+# ocaml-cryptgps, which is not available.
+
+RDEPEND=">=dev-ml/findlib-1.0
+ pcre? ( >=dev-ml/pcre-ocaml-5:= )
+ >=dev-lang/ocaml-3.10.2:=[ocamlopt?]
+ tk? ( dev-ml/labltk:= )
+ ssl? ( net-libs/gnutls:= )
+ gtk? ( >=dev-ml/lablgtk-2:= )
+ kerberos? ( virtual/krb5 )
+ zip? ( dev-ml/camlzip:= )
+ "
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+"
+
+S=${WORKDIR}/${MY_P}
+
+ocamlnet_use_with() {
+ if use $1; then
+ echo "-with-$2"
+ else
+ echo "-without-$2"
+ fi
+}
+
+ocamlnet_use_enable() {
+ if use $1; then
+ echo "-enable-$2"
+ else
+ echo "-disable-$2"
+ fi
+}
+
+src_configure() {
+ ./configure \
+ -bindir /usr/bin \
+ -datadir /usr/share/${PN} \
+ $(ocamlnet_use_enable ssl gnutls) \
+ $(ocamlnet_use_enable gtk gtk2) \
+ $(ocamlnet_use_enable kerberos gssapi) \
+ $(ocamlnet_use_enable pcre pcre) \
+ $(ocamlnet_use_enable tk tcl) \
+ $(ocamlnet_use_enable zip zip) \
+ $(ocamlnet_use_with httpd nethttpd) \
+ || die "Error : econf failed!"
+}
+
+src_compile() {
+ emake -j1 all
+ if use ocamlopt; then
+ emake -j1 opt
+ fi
+}
+
+src_install() {
+ export STRIP_MASK="*/bin/*"
+ findlib_src_install
+}