summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-19 21:31:01 +0000
committerSam James <sam@gentoo.org>2020-10-20 01:37:16 +0000
commit43e21d90a186114101a27d8aad901501f38912a3 (patch)
tree17f64ca67b47fa87d9b9f1122b1f88603cc1a27b /dev-ml/ocurl/ocurl-0.9.1.ebuild
parentsci-libs/tensorflow: Fix compile error against grpc-1.32 (diff)
downloadgentoo-43e21d90a186114101a27d8aad901501f38912a3.tar.gz
gentoo-43e21d90a186114101a27d8aad901501f38912a3.tar.bz2
gentoo-43e21d90a186114101a27d8aad901501f38912a3.zip
dev-ml/ocurl: bump to 0.9.1
Closes: https://bugs.gentoo.org/743595 Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocurl/ocurl-0.9.1.ebuild')
-rw-r--r--dev-ml/ocurl/ocurl-0.9.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-ml/ocurl/ocurl-0.9.1.ebuild b/dev-ml/ocurl/ocurl-0.9.1.ebuild
new file mode 100644
index 000000000000..e8019096fa82
--- /dev/null
+++ b/dev-ml/ocurl/ocurl-0.9.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit findlib
+
+DESCRIPTION="OCaml interface to the libcurl library"
+HOMEPAGE="http://forge.ocamlcore.org/projects/ocurl/ https://github.com/ygrek/ocurl"
+LICENSE="MIT"
+SRC_URI="https://github.com/ygrek/ocurl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0/${PV}"
+IUSE="examples +ocamlopt"
+
+BDEPEND="virtual/pkgconfig"
+RDEPEND=">=net-misc/curl-7.9.8
+ dev-ml/lwt:=
+ dev-ml/camlp4:=
+ >=dev-lang/ocaml-3.12:=[ocamlopt?]"
+DEPEND="${RDEPEND}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~x86"
+
+src_compile() {
+ emake -j1 all
+}
+
+src_install() {
+ findlib_src_install
+ dodoc CHANGES.txt README.md
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}