summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2023-03-05 11:31:00 +0100
committerAlfredo Tupone <tupone@gentoo.org>2023-03-05 11:36:24 +0100
commit371d48243cf8ca0f506710a94685b1a58c9e38e2 (patch)
tree8ba98d25a435387e95dc1936fd490e0f27181375 /dev-ml/odoc/odoc-2.2.0-r2.ebuild
parentkde-misc/plasma-pass: add 1.2.1 (diff)
downloadgentoo-371d48243cf8ca0f506710a94685b1a58c9e38e2.tar.gz
gentoo-371d48243cf8ca0f506710a94685b1a58c9e38e2.tar.bz2
gentoo-371d48243cf8ca0f506710a94685b1a58c9e38e2.zip
dev-ml/odoc: only support >=dune-3
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/odoc/odoc-2.2.0-r2.ebuild')
-rw-r--r--dev-ml/odoc/odoc-2.2.0-r2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-ml/odoc/odoc-2.2.0-r2.ebuild b/dev-ml/odoc/odoc-2.2.0-r2.ebuild
new file mode 100644
index 000000000000..24702587b03d
--- /dev/null
+++ b/dev-ml/odoc/odoc-2.2.0-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml documentation generator"
+HOMEPAGE="http://github.com/ocaml/odoc/"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="test" # ocaml-crunch not in the tree
+
+RDEPEND="
+ >=dev-ml/dune-3
+ dev-ml/astring:=
+ dev-ml/cmdliner:=
+ dev-ml/cppo:=
+ dev-ml/fmt:=
+ dev-ml/fpath:=
+ dev-ml/odoc-parser:=
+ dev-ml/result:=
+ dev-ml/tyxml:=
+"
+DEPEND="${RDEPEND}"