summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-12-21 14:24:01 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-12-21 14:24:19 +0100
commit5d4359acfce887c54d2b6634113c87c06129ca8d (patch)
treea740f62986e16c424c80e6806df63d7cfb7f13f7 /dev-ml/odoc
parentmedia-libs/hamlib: add 4.5.1 (diff)
downloadgentoo-5d4359acfce887c54d2b6634113c87c06129ca8d.tar.gz
gentoo-5d4359acfce887c54d2b6634113c87c06129ca8d.tar.bz2
gentoo-5d4359acfce887c54d2b6634113c87c06129ca8d.zip
dev-ml/odoc: new package, add 2.2.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/odoc')
-rw-r--r--dev-ml/odoc/Manifest1
-rw-r--r--dev-ml/odoc/metadata.xml16
-rw-r--r--dev-ml/odoc/odoc-2.2.0.ebuild27
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/odoc/Manifest b/dev-ml/odoc/Manifest
new file mode 100644
index 000000000000..33ea89ce7bba
--- /dev/null
+++ b/dev-ml/odoc/Manifest
@@ -0,0 +1 @@
+DIST odoc-2.2.0.tbz 1548871 BLAKE2B 251c823e5f93e8080d52486e9d048a0c31651b6ea9d4bfdc3202488d7bcd750f9c2899189b943500253bf1e6041cf0283ed5e57c34d1a7d538c7c3710fb9a260 SHA512 9f8fc2ee6b25629474e8aa69dd460becab9277261578af0f7b97f7f779cc5f1056d1b5f14ab583b9b94ea097e5df2d6e35040f2a4887021209705486f9d44a22
diff --git a/dev-ml/odoc/metadata.xml b/dev-ml/odoc/metadata.xml
new file mode 100644
index 000000000000..abc13e762b3e
--- /dev/null
+++ b/dev-ml/odoc/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Odoc is a documentation generator for OCaml. It reads doc comments,
+ delimited with (** ... *), and outputs HTML
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml/odoc/issues/</bugs-to>
+ <remote-id type="github">ocaml/odoc</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/odoc/odoc-2.2.0.ebuild b/dev-ml/odoc/odoc-2.2.0.ebuild
new file mode 100644
index 000000000000..a8dbd0b6ee6c
--- /dev/null
+++ b/dev-ml/odoc/odoc-2.2.0.ebuild
@@ -0,0 +1,27 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="OCaml documentation generator"
+HOMEPAGE="http://github.com/ocaml/odoc"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+RESTRICT="test" # ocaml-crunch not in the tree
+
+RDEPEND="
+ dev-ml/odoc-parser:=
+ dev-ml/astring:=
+ dev-ml/cmdliner:=
+ dev-ml/cppo:=
+ dev-ml/fpath:=
+ dev-ml/result:=
+ dev-ml/tyxml:=
+"
+DEPEND="${RDEPEND}"