summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-08 17:00:09 +0000
committerSam James <sam@gentoo.org>2021-02-08 17:20:53 +0000
commit6d8e3059bc2b789600af9e91e6b8dc4f438e8dda (patch)
tree9f67baaf13d4f515691eca36f9841e13bea855fa /dev-ml/opam-repository/opam-repository-2.0.8.ebuild
parentdev-ml/opam-core: bump to 2.0.8 (diff)
downloadgentoo-6d8e3059bc2b789600af9e91e6b8dc4f438e8dda.tar.gz
gentoo-6d8e3059bc2b789600af9e91e6b8dc4f438e8dda.tar.bz2
gentoo-6d8e3059bc2b789600af9e91e6b8dc4f438e8dda.zip
dev-ml/opam-repository: bump to 2.0.8
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/opam-repository/opam-repository-2.0.8.ebuild')
-rw-r--r--dev-ml/opam-repository/opam-repository-2.0.8.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-ml/opam-repository/opam-repository-2.0.8.ebuild b/dev-ml/opam-repository/opam-repository-2.0.8.ebuild
new file mode 100644
index 000000000000..c0970787f1db
--- /dev/null
+++ b/dev-ml/opam-repository/opam-repository-2.0.8.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="opam repository libraries"
+HOMEPAGE="https://opam.ocaml.org/ https://github.com/ocaml/opam"
+SRC_URI="https://github.com/ocaml/opam/archive/${PV/_/-}.tar.gz -> opam-${PV}.tar.gz"
+S="${WORKDIR}/opam-${PV/_/-}"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt"
+RESTRICT="test"
+
+RDEPEND="
+ ~dev-ml/opam-format-${PV}:=
+ dev-ml/re:=
+ dev-ml/dose3:=
+ dev-ml/opam-file-format:=
+"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ cat <<- EOF >> "${S}/dune"
+ (env
+ (dev
+ (flags (:standard -warn-error -3-9-33)))
+ (release
+ (flags (:standard -warn-error -3-9-33))))
+ EOF
+}