summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-22 23:08:06 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-22 23:08:06 +0200
commit3963bd109f2693f1a929b14572ec9127d1586a2f (patch)
treed460ffa95636b5b19bb2a39d182375b4042d58aa /dev-ml/parmap/parmap-1.2.4-r1.ebuild
parentapp-text/tkman: use subslot dep on tcl (diff)
downloadgentoo-3963bd109f2693f1a929b14572ec9127d1586a2f.tar.gz
gentoo-3963bd109f2693f1a929b14572ec9127d1586a2f.tar.bz2
gentoo-3963bd109f2693f1a929b14572ec9127d1586a2f.zip
dev-ml/parmap: depends on dune-configurator subslot
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/parmap/parmap-1.2.4-r1.ebuild')
-rw-r--r--dev-ml/parmap/parmap-1.2.4-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-ml/parmap/parmap-1.2.4-r1.ebuild b/dev-ml/parmap/parmap-1.2.4-r1.ebuild
new file mode 100644
index 000000000000..2cab0f41c790
--- /dev/null
+++ b/dev-ml/parmap/parmap-1.2.4-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+MY_PV="${PV/_/-}"
+DESCRIPTION="Library to exploit multicore architectures for OCaml programs"
+HOMEPAGE="https://www.dicosmo.org/code/parmap/"
+SRC_URI="https://github.com/rdicosmo/parmap/archive/${MY_PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${MY_PV/+/-}"
+
+LICENSE="LGPL-2-with-linking-exception"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+BDEPEND="dev-ml/dune-configurator:="
+RDEPEND=">=dev-lang/ocaml-4.03:=[ocamlopt?]"
+DEPEND="${RDEPEND}"