summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-05-01 19:45:23 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-05-03 11:13:52 +0200
commit294b229cd1f177bd30b79d0fa5193c113be7cf96 (patch)
tree6013cfbe71781f2594e966cbcea0d6f0c3890b89 /dev-ml/ppx_core/ppx_core-113.33.00.ebuild
parentsci-mathematics/coq: fix build with ocaml 4.03 (diff)
downloadgentoo-294b229cd1f177bd30b79d0fa5193c113be7cf96.tar.gz
gentoo-294b229cd1f177bd30b79d0fa5193c113be7cf96.tar.bz2
gentoo-294b229cd1f177bd30b79d0fa5193c113be7cf96.zip
dev-ml/ppx_core: fix build with ocaml 4.03
Package-Manager: portage-2.2.28 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_core/ppx_core-113.33.00.ebuild')
-rw-r--r--dev-ml/ppx_core/ppx_core-113.33.00.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/dev-ml/ppx_core/ppx_core-113.33.00.ebuild b/dev-ml/ppx_core/ppx_core-113.33.00.ebuild
index d00d0966dd88..1ba11129cbb3 100644
--- a/dev-ml/ppx_core/ppx_core-113.33.00.ebuild
+++ b/dev-ml/ppx_core/ppx_core-113.33.00.ebuild
@@ -4,7 +4,7 @@
EAPI="5"
-inherit oasis
+inherit oasis eutils
DESCRIPTION="Standard library for ppx rewriters"
HOMEPAGE="http://www.janestreet.com/ocaml"
@@ -19,6 +19,10 @@ DEPEND="dev-ml/ppx_tools:="
RDEPEND="${DEPEND}"
DEPEND="${DEPEND} dev-ml/opam"
+src_prepare() {
+ has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
+}
+
src_configure() {
emake setup.exe
OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure