summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2021-01-16 14:03:29 +0100
committerAlfredo Tupone <tupone@gentoo.org>2021-01-16 14:03:43 +0100
commit6afe5b8bff982f7b420567c9fbb3deba4accd30a (patch)
tree85d9e49f9dcf0539873943b91ab3b1a757323f22 /dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
parentdev-util/cppunit: Synced live ebuild (diff)
downloadgentoo-6afe5b8bff982f7b420567c9fbb3deba4accd30a.tar.gz
gentoo-6afe5b8bff982f7b420567c9fbb3deba4accd30a.tar.bz2
gentoo-6afe5b8bff982f7b420567c9fbb3deba4accd30a.zip
dev-ml/ppx_deriving: version bump to 5.2
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild')
-rw-r--r--dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild b/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
new file mode 100644
index 000000000000..73a1495d16a7
--- /dev/null
+++ b/dev-ml/ppx_deriving/ppx_deriving-5.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Type-driven code generation for OCaml"
+HOMEPAGE="https://github.com/ocaml-ppx/ppx_deriving"
+SRC_URI="https://github.com/ocaml-ppx/ppx_deriving/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ dev-ml/ppx_tools:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ppx_derivers:=
+ >=dev-ml/ppxlib-0.20.0:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${RDEPEND}
+ dev-ml/cppo
+ test? ( dev-ml/ounit2 )"