summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-09-08 10:48:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2016-09-08 16:56:53 +0200
commit43cb834e17678031554ade901a24c038bd7b211c (patch)
tree47b9ce4e4891c661348605a120e769ac9bad884e /dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
parentdev-ml/ppx_import: initial import; ebuild by me (diff)
downloadgentoo-43cb834e17678031554ade901a24c038bd7b211c.tar.gz
gentoo-43cb834e17678031554ade901a24c038bd7b211c.tar.bz2
gentoo-43cb834e17678031554ade901a24c038bd7b211c.zip
dev-ml/ppx_deriving_yojson: initial import; ebuild by me
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild')
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
new file mode 100644
index 000000000000..8b0dcc23f489
--- /dev/null
+++ b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A Yojson codec generator for OCaml"
+HOMEPAGE="A Yojson codec generator for OCaml"
+SRC_URI="https://github.com/whitequark/ppx_deriving_yojson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt test"
+
+DEPEND="
+ dev-lang/ocaml:=[ocamlopt?]
+ dev-ml/yojson:=
+ dev-ml/result:=
+ >=dev-ml/ppx_deriving-4:=
+ dev-ml/cppo:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND}
+ dev-ml/findlib
+ dev-ml/ocamlbuild
+ test? ( dev-ml/ounit dev-ml/ppx_import )"
+
+src_compile() {
+ cp pkg/META.in pkg/META
+ ocaml pkg/build.ml \
+ native=$(usex ocamlopt true false) \
+ native-dynlink=$(usex ocamlopt true false) \
+ || die
+}
+
+src_test() {
+ ocamlbuild -j 0 -use-ocamlfind -classic-display src_test/test_ppx_yojson.byte -- || die
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${T}/dontinstallit" \
+ ${PN}.install || die
+ dodoc CHANGELOG.md README.md
+}