summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-14 17:25:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-14 17:26:07 +0100
commite73cdb8ec3060b24e3ae4a568659547e8050dc71 (patch)
tree027bca129ccaca71fc75a2945302675c20f8c871 /dev-ml/ppx_deriving_yojson
parentsci-electronics/oregano: Remove last-rited pkg (diff)
downloadgentoo-e73cdb8ec3060b24e3ae4a568659547e8050dc71.tar.gz
gentoo-e73cdb8ec3060b24e3ae4a568659547e8050dc71.tar.bz2
gentoo-e73cdb8ec3060b24e3ae4a568659547e8050dc71.zip
dev-ml/*: Remove first set of unneeded leaf packages
Bug: https://bugs.gentoo.org/695782 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_deriving_yojson')
-rw-r--r--dev-ml/ppx_deriving_yojson/Manifest1
-rw-r--r--dev-ml/ppx_deriving_yojson/files/ocaml405.patch76
-rw-r--r--dev-ml/ppx_deriving_yojson/metadata.xml8
-rw-r--r--dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild45
4 files changed, 0 insertions, 130 deletions
diff --git a/dev-ml/ppx_deriving_yojson/Manifest b/dev-ml/ppx_deriving_yojson/Manifest
deleted file mode 100644
index 6889c4326cf0..000000000000
--- a/dev-ml/ppx_deriving_yojson/Manifest
+++ /dev/null
@@ -1 +0,0 @@
-DIST ppx_deriving_yojson-3.0.tar.gz 18111 BLAKE2B eaf8d380b8ff606bebff4050af9fb22624b404f106518a0f68b23866e66459f74c0984970ae0bbbdb67d2f71264a832850a8e03740c8fb207bc70abe89a61219 SHA512 70c690d880ff652f9f92e95af047e87726bab48100e9325406eef7a9ed80f439df7292324de56cd17a93c6ad6bc9c1e7ce6edcd7c3b336352f0df4bfa7c7b81c
diff --git a/dev-ml/ppx_deriving_yojson/files/ocaml405.patch b/dev-ml/ppx_deriving_yojson/files/ocaml405.patch
deleted file mode 100644
index 33440fabdd19..000000000000
--- a/dev-ml/ppx_deriving_yojson/files/ocaml405.patch
+++ /dev/null
@@ -1,76 +0,0 @@
-Index: ppx_deriving_yojson-3.0/src/ppx_deriving_yojson.cppo.ml
-===================================================================
---- ppx_deriving_yojson-3.0.orig/src/ppx_deriving_yojson.cppo.ml
-+++ ppx_deriving_yojson-3.0/src/ppx_deriving_yojson.cppo.ml
-@@ -260,7 +260,7 @@ let ser_str_of_type ~options ~path ({ pt
- let polymorphize_ser = Ppx_deriving.poly_arrow_of_type_decl
- (fun var -> [%type: [%t var] -> Yojson.Safe.json]) type_decl
- in
-- let ty = Typ.poly poly_vars (polymorphize_ser [%type: [%t typ] -> Yojson.Safe.json]) in
-+ let ty = Typ.poly (List.map Location.mknoloc poly_vars) (polymorphize_ser [%type: [%t typ] -> Yojson.Safe.json]) in
- let default_fun =
- let type_path = String.concat "." (path @ [type_decl.ptype_name.txt]) in
- let e_type_path = Exp.constant (Pconst_string (type_path, None)) in
-@@ -270,7 +270,7 @@ let ser_str_of_type ~options ~path ({ pt
- in
- let poly_fun = polymorphize default_fun in
- let poly_fun =
-- (Ppx_deriving.fold_left_type_decl (fun exp name -> Exp.newtype name exp) poly_fun type_decl)
-+ (Ppx_deriving.fold_left_type_decl (fun exp name -> Exp.newtype (Location.mknoloc name) exp) poly_fun type_decl)
- in
- let mod_name = "M_"^to_yojson_name in
- let typ = Type.mk ~kind:(Ptype_record [Type.field ~mut:Mutable (mknoloc "f") ty])
-@@ -337,7 +337,7 @@ let ser_str_of_type ~options ~path ({ pt
- raise_errorf ~loc "%s cannot be derived for fully abstract types" deriver
- in
- let ty = ser_type_of_decl ~options ~path type_decl in
-- let fv = Ppx_deriving.free_vars_in_core_type ty in
-+ let fv = List.map Location.mknoloc (Ppx_deriving.free_vars_in_core_type ty) in
- let poly_type = Typ.force_poly @@ Typ.poly fv @@ ty in
- let var = pvar (Ppx_deriving.mangle_type_decl (`Suffix "to_yojson") type_decl) in
- ([],
-@@ -431,7 +431,7 @@ let desu_str_of_type ~options ~path ({ p
- raise_errorf ~loc "%s: extensible type manifest should be a type name" deriver
- | None ->
- let poly_vars = List.rev
-- (Ppx_deriving.fold_left_type_decl (fun acc name -> name :: acc) [] type_decl)
-+ (List.map Location.mknoloc (Ppx_deriving.fold_left_type_decl (fun acc name -> name :: acc) [] type_decl))
- in
- let polymorphize_desu = Ppx_deriving.poly_arrow_of_type_decl
- (fun var -> [%type: Yojson.Safe.json -> [%t error_or var]]) type_decl in
-@@ -441,7 +441,7 @@ let desu_str_of_type ~options ~path ({ p
- let default_fun = Exp.function_ [Exp.case [%pat? _] top_error] in
- let poly_fun = polymorphize default_fun in
- let poly_fun =
-- (Ppx_deriving.fold_left_type_decl (fun exp name -> Exp.newtype name exp) poly_fun type_decl)
-+ (Ppx_deriving.fold_left_type_decl (fun exp name -> Exp.newtype (Location.mknoloc name) exp) poly_fun type_decl)
- in
- let mod_name = "M_"^of_yojson_name in
- let typ = Type.mk ~kind:(Ptype_record [Type.field ~mut:Mutable (mknoloc "f") ty])
-@@ -514,7 +514,7 @@ let desu_str_of_type ~options ~path ({ p
- raise_errorf ~loc "%s cannot be derived for fully abstract types" deriver
- in
- let ty = desu_type_of_decl ~options ~path type_decl in
-- let fv = Ppx_deriving.free_vars_in_core_type ty in
-+ let fv = List.map Location.mknoloc (Ppx_deriving.free_vars_in_core_type ty) in
- let poly_type = Typ.force_poly @@ Typ.poly fv @@ ty in
- let var = pvar (Ppx_deriving.mangle_type_decl (`Suffix "of_yojson") type_decl) in
- ([],
-@@ -579,7 +579,7 @@ let ser_sig_of_type ~options ~path type_
- (`PrefixSuffix ("M", "to_yojson")) type_decl
- in
- let poly_vars = List.rev
-- (Ppx_deriving.fold_left_type_decl (fun acc name -> name :: acc) [] type_decl)
-+ (List.map Location.mknoloc (Ppx_deriving.fold_left_type_decl (fun acc name -> name :: acc) [] type_decl))
- in
- let typ = Ppx_deriving.core_type_of_type_decl type_decl in
- let polymorphize_ser = Ppx_deriving.poly_arrow_of_type_decl
-@@ -614,7 +614,7 @@ let desu_sig_of_type ~options ~path type
- (`PrefixSuffix ("M", "of_yojson")) type_decl
- in
- let poly_vars = List.rev
-- (Ppx_deriving.fold_left_type_decl (fun acc name -> name :: acc) [] type_decl)
-+ (List.map Location.mknoloc (Ppx_deriving.fold_left_type_decl (fun acc name -> name :: acc) [] type_decl))
- in
- let typ = Ppx_deriving.core_type_of_type_decl type_decl in
- let polymorphize_desu = Ppx_deriving.poly_arrow_of_type_decl
diff --git a/dev-ml/ppx_deriving_yojson/metadata.xml b/dev-ml/ppx_deriving_yojson/metadata.xml
deleted file mode 100644
index ae697b3c4ec7..000000000000
--- a/dev-ml/ppx_deriving_yojson/metadata.xml
+++ /dev/null
@@ -1,8 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <!-- maintainer-needed -->
- <upstream>
- <remote-id type="github">whitequark/ppx_deriving_yojson</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild b/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
deleted file mode 100644
index efadbf89ec58..000000000000
--- a/dev-ml/ppx_deriving_yojson/ppx_deriving_yojson-3.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit eutils opam
-
-DESCRIPTION="A Yojson codec generator for OCaml"
-HOMEPAGE="https://github.com/whitequark/ppx_deriving_yojson/"
-SRC_URI="https://github.com/whitequark/ppx_deriving_yojson/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="+ocamlopt test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-lang/ocaml:=[ocamlopt?]
- dev-ml/yojson:=
- dev-ml/result:=
- >=dev-ml/ppx_deriving-4:=
- dev-ml/cppo:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- dev-ml/findlib
- dev-ml/ocamlbuild
- test? ( dev-ml/ounit dev-ml/ppx_import )"
-
-src_prepare() {
- has_version '>=dev-lang/ocaml-4.05_rc' && epatch "${FILESDIR}/ocaml405.patch"
-}
-
-src_compile() {
- cp pkg/META.in pkg/META
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
-}
-
-src_test() {
- ocamlbuild -j 0 -use-ocamlfind -classic-display src_test/test_ppx_yojson.byte -- || die
-}