summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 16:39:59 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:44 +0200
commit11195c2b1ef4c6a0936f0e9ca73913155ee4f010 (patch)
treefbc6c1188b7ca8c7bf575932336e9065f4888d53 /dev-ml/ppx_driver/ppx_driver-0.9.0.ebuild
parentdev-ml/ppx_optcomp: Bump to 0.9.0 (diff)
downloadgentoo-11195c2b1ef4c6a0936f0e9ca73913155ee4f010.tar.gz
gentoo-11195c2b1ef4c6a0936f0e9ca73913155ee4f010.tar.bz2
gentoo-11195c2b1ef4c6a0936f0e9ca73913155ee4f010.zip
dev-ml/ppx_driver: Bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_driver/ppx_driver-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_driver/ppx_driver-0.9.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-ml/ppx_driver/ppx_driver-0.9.0.ebuild b/dev-ml/ppx_driver/ppx_driver-0.9.0.ebuild
new file mode 100644
index 000000000000..ca8838223d31
--- /dev/null
+++ b/dev-ml/ppx_driver/ppx_driver-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Feature-full driver for OCaml AST transformers"
+HOMEPAGE="https://github.com/janestreet/ppx_driver"
+SRC_URI="https://github.com/janestreet/ppx_driver/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_optcomp:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/ocamlbuild:="
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}