summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-16 21:41:02 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-17 10:35:14 +0200
commit019a1fdf15664be1dcd3026218d91f103f6f4263 (patch)
tree2072f11c3a89543d3e14046a682c52c96cc1a1b1 /dev-ml/ppx_fields_conv/ppx_fields_conv-0.9.0-r1.ebuild
parentdev-ml/ppx_sexp_conv: add missing dev-lang/ocaml:= dep (diff)
downloadgentoo-019a1fdf15664be1dcd3026218d91f103f6f4263.tar.gz
gentoo-019a1fdf15664be1dcd3026218d91f103f6f4263.tar.bz2
gentoo-019a1fdf15664be1dcd3026218d91f103f6f4263.zip
dev-ml/ppx_fields_conv: revbump for propagating previous fix
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_fields_conv/ppx_fields_conv-0.9.0-r1.ebuild')
-rw-r--r--dev-ml/ppx_fields_conv/ppx_fields_conv-0.9.0-r1.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ppx_fields_conv/ppx_fields_conv-0.9.0-r1.ebuild b/dev-ml/ppx_fields_conv/ppx_fields_conv-0.9.0-r1.ebuild
new file mode 100644
index 000000000000..eff75b699880
--- /dev/null
+++ b/dev-ml/ppx_fields_conv/ppx_fields_conv-0.9.0-r1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Generation of accessor and iteration functions for ocaml records"
+HOMEPAGE="https://github.com/janestreet/ppx_fields_conv"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ppx_type_conv:=
+ dev-ml/fieldslib:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}