summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Wright <gienah@gentoo.org>2020-10-13 17:32:53 +1100
committerMark Wright <gienah@gentoo.org>2020-10-13 23:53:37 +1100
commitf2fffc1ad222ea67a45291aa9483773bf16b09af (patch)
tree458c25f99b972dd9c859288a18f73e5f08dcb3f6 /dev-ml/ppx_fixed_literal/ppx_fixed_literal-0.14.0.ebuild
parentdev-ml/ppxfind: Dependency of dev-ml/ppx_deriving (diff)
downloadgentoo-f2fffc1ad222ea67a45291aa9483773bf16b09af.tar.gz
gentoo-f2fffc1ad222ea67a45291aa9483773bf16b09af.tar.bz2
gentoo-f2fffc1ad222ea67a45291aa9483773bf16b09af.zip
dev-ml/ppx_fixed_literal: Dependency of dev-ml/ppx_jane
Co-Author: Alexis Ballier <aballier@gentoo.org> Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Mark Wright <gienah@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_fixed_literal/ppx_fixed_literal-0.14.0.ebuild')
-rw-r--r--dev-ml/ppx_fixed_literal/ppx_fixed_literal-0.14.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-ml/ppx_fixed_literal/ppx_fixed_literal-0.14.0.ebuild b/dev-ml/ppx_fixed_literal/ppx_fixed_literal-0.14.0.ebuild
new file mode 100644
index 000000000000..07e00094a1b7
--- /dev/null
+++ b/dev-ml/ppx_fixed_literal/ppx_fixed_literal-0.14.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Simpler notation for fixed point literals"
+HOMEPAGE="https://github.com/janestreet/ppx_fixed_literal"
+SRC_URI="https://github.com/janestreet/ppx_fixed_literal/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base:=
+ dev-ml/ppxlib:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+"
+RDEPEND="${DEPEND}"