summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-14 17:25:05 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-14 17:26:07 +0100
commite73cdb8ec3060b24e3ae4a568659547e8050dc71 (patch)
tree027bca129ccaca71fc75a2945302675c20f8c871 /dev-ml/ppx_import/ppx_import-1.2.ebuild
parentsci-electronics/oregano: Remove last-rited pkg (diff)
downloadgentoo-e73cdb8ec3060b24e3ae4a568659547e8050dc71.tar.gz
gentoo-e73cdb8ec3060b24e3ae4a568659547e8050dc71.tar.bz2
gentoo-e73cdb8ec3060b24e3ae4a568659547e8050dc71.zip
dev-ml/*: Remove first set of unneeded leaf packages
Bug: https://bugs.gentoo.org/695782 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_import/ppx_import-1.2.ebuild')
-rw-r--r--dev-ml/ppx_import/ppx_import-1.2.ebuild40
1 files changed, 0 insertions, 40 deletions
diff --git a/dev-ml/ppx_import/ppx_import-1.2.ebuild b/dev-ml/ppx_import/ppx_import-1.2.ebuild
deleted file mode 100644
index 56b86b5efe91..000000000000
--- a/dev-ml/ppx_import/ppx_import-1.2.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-inherit opam
-
-DESCRIPTION="A syntax extension for importing declarations from interface files"
-HOMEPAGE="https://github.com/whitequark/ppx_import"
-SRC_URI="https://github.com/whitequark/ppx_import/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE="+ocamlopt test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-lang/ocaml:=[ocamlopt?]
- dev-ml/ppx_tools:=
- dev-ml/cppo:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND}
- test? ( dev-ml/ounit dev-ml/ppx_deriving )
- dev-ml/ocamlbuild
- dev-ml/findlib
-"
-
-src_compile() {
- cp pkg/META.in pkg/META
- ocaml pkg/build.ml \
- native=$(usex ocamlopt true false) \
- native-dynlink=$(usex ocamlopt true false) \
- || die
-}
-
-src_test() {
- ocamlbuild -classic-display -use-ocamlfind src_test/test_ppx_import.byte -- || die
-}