summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-04-25 21:37:42 +0200
committerAlfredo Tupone <tupone@gentoo.org>2022-04-25 21:38:12 +0200
commit63c9deb49045fde202a21684ceb4f05e22440bdc (patch)
tree83a5ee5ebd5dfeace026bf302fe5615a1ffc6614 /dev-ml/ppx_jane
parentpackage.mask: add ppx_jane to janestreet mask (diff)
downloadgentoo-63c9deb49045fde202a21684ceb4f05e22440bdc.tar.gz
gentoo-63c9deb49045fde202a21684ceb4f05e22440bdc.tar.bz2
gentoo-63c9deb49045fde202a21684ceb4f05e22440bdc.zip
dev-ml/ppx_jane: 0.15.0 bump
Closes: https://bugs.gentoo.org/838703 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_jane')
-rw-r--r--dev-ml/ppx_jane/Manifest1
-rw-r--r--dev-ml/ppx_jane/ppx_jane-0.15.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-ml/ppx_jane/Manifest b/dev-ml/ppx_jane/Manifest
index 7c62b94aff8a..ebce4217d319 100644
--- a/dev-ml/ppx_jane/Manifest
+++ b/dev-ml/ppx_jane/Manifest
@@ -1 +1,2 @@
DIST ppx_jane-0.14.0.tar.gz 4593 BLAKE2B 787fc0701ba0361446cb210c23469881da8fbab28460262a7bdca8723af158ed8deeb4597a31c8d89a4d44e5263c74e0ebc504b83827e0a34870a503b2ea9053 SHA512 b51bef2330ebb8d361b3f856a0526a5290664b68fa56a02de7020b0e27aaf5a378f1b22fc9a24007bfc812af67eb79343b2bdc3ca550108393323b99e29c623d
+DIST ppx_jane-0.15.0.tar.gz 4647 BLAKE2B c8916e7327301a2dc54b36cc29ad61f3ef016aac2f07dd8c1421a84b144b406e9b189e229680f700efaf2138c508f30e0d132dcf726165ac60ad3120f67549d7 SHA512 e594a0caea66e0f976615b2a1db50aad89389888678d9ec7c023b2adb3211817a841a5065de9a65956bde0cb6088ce1b0b3afed6b57b618b9b50e5c07684e3fa
diff --git a/dev-ml/ppx_jane/ppx_jane-0.15.0.ebuild b/dev-ml/ppx_jane/ppx_jane-0.15.0.ebuild
new file mode 100644
index 000000000000..c20798f7d4e8
--- /dev/null
+++ b/dev-ml/ppx_jane/ppx_jane-0.15.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Standard Jane Street ppx rewriters"
+HOMEPAGE="https://github.com/janestreet/ppx_jane"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1-2)"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt"
+
+DEPEND="
+ dev-ml/base_quickcheck:${SLOT}
+ dev-ml/ppx_bin_prot:${SLOT}
+ dev-ml/ppx_disable_unused_warnings:${SLOT}
+ dev-ml/ppx_expect:${SLOT}
+ dev-ml/ppx_fixed_literal:${SLOT}
+ dev-ml/ppx_ignore_instrumentation:${SLOT}
+ dev-ml/ppx_log:${SLOT}
+ dev-ml/ppx_module_timer:${SLOT}
+ dev-ml/ppx_optional:${SLOT}
+ dev-ml/ppx_pipebang:${SLOT}
+ dev-ml/ppx_stable:${SLOT}
+ dev-ml/ppx_string:${SLOT}
+ dev-ml/ppx_typerep_conv:${SLOT}
+"
+RDEPEND="${DEPEND}"