summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-04-01 18:49:32 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-04-02 10:37:59 +0200
commit6f0a36a698e75cba55ca15b22bf2368561f6590d (patch)
tree0e1c35e2872ffccf3b89384eb9fa394cb066c5cb /dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild
parentdev-ml/typerep_extended: bump to 0.9.0 (diff)
downloadgentoo-6f0a36a698e75cba55ca15b22bf2368561f6590d.tar.gz
gentoo-6f0a36a698e75cba55ca15b22bf2368561f6590d.tar.bz2
gentoo-6f0a36a698e75cba55ca15b22bf2368561f6590d.zip
dev-ml/ppx_pipebang: bump to 0.9.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild')
-rw-r--r--dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild b/dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild
new file mode 100644
index 000000000000..8d864327b5a2
--- /dev/null
+++ b/dev-ml/ppx_pipebang/ppx_pipebang-0.9.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="A ppx rewriter that inlines reverse application operators |> and |!"
+HOMEPAGE="https://github.com/janestreet/ppx_pipebang"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+ dev-lang/ocaml:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_metaquot:=
+ dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}