summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-10-15 04:28:21 +0100
committerSam James <sam@gentoo.org>2021-10-15 04:28:21 +0100
commita6c01551d7c31debec3db70595b9311cdb24a998 (patch)
treedb802953a6dd37daeb0d2aa0192434d85f12c543 /dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r1.ebuild
parentdev-ml/ocaml-migrate-parsetree: add lower bound on dune (diff)
downloadgentoo-a6c01551d7c31debec3db70595b9311cdb24a998.tar.gz
gentoo-a6c01551d7c31debec3db70595b9311cdb24a998.tar.bz2
gentoo-a6c01551d7c31debec3db70595b9311cdb24a998.zip
dev-ml/ppx_sexp_conv: adjust ppxlib upper bound
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r1.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r1.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r1.ebuild
new file mode 100644
index 000000000000..7cdc3f5e627e
--- /dev/null
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-0.14.2-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Support Library for type-driven code generators"
+HOMEPAGE="https://github.com/janestreet/ppx_sexp_conv"
+SRC_URI="https://github.com/janestreet/ppx_sexp_conv/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="amd64 arm arm64 ppc ppc64 x86"
+IUSE="+ocamlopt"
+
+# Upper bound on ppxlib for bug #769536
+DEPEND="
+ >=dev-ml/base-0.14.0:=
+ dev-ml/findlib:=
+ >=dev-ml/ppxlib-0.18.0:=
+ <dev-ml/ppxlib-0.21.0:=
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.0.0:=
+ dev-ml/cinaps:=
+ dev-ml/sexplib0:=
+"
+RDEPEND="${DEPEND}"