summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 18:55:15 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit49e917034038f91c76f41ddc2cc65811b602acc6 (patch)
tree046e1cb8d675dda828d5eccf23ef2571cc448764 /dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild
parentdev-ml/ppx_compare: use proper install method. (diff)
downloadgentoo-49e917034038f91c76f41ddc2cc65811b602acc6.tar.gz
gentoo-49e917034038f91c76f41ddc2cc65811b602acc6.tar.bz2
gentoo-49e917034038f91c76f41ddc2cc65811b602acc6.zip
dev-ml/ppx_sexp_conv: use proper install method
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild26
1 files changed, 20 insertions, 6 deletions
diff --git a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild
index 97d8fd7f80f4..c94e89c8eee8 100644
--- a/dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild
+++ b/dev-ml/ppx_sexp_conv/ppx_sexp_conv-113.24.00.ebuild
@@ -6,10 +6,9 @@ EAPI="5"
inherit oasis
-MY_P=${PN/-/_}-${PV}
DESCRIPTION="Support Library for type-driven code generators"
HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
LICENSE="Apache-2.0"
SLOT="0/${PV}"
@@ -23,7 +22,22 @@ DEPEND="dev-ml/ppx_tools:=
"
RDEPEND="${DEPEND}"
-
-S="${WORKDIR}/${MY_P}"
-
-DOCS=( CHANGES.md )
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+ dodoc CHANGES.md
+}