summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2016-02-05 19:15:24 +0100
committerAlexis Ballier <aballier@gentoo.org>2016-02-05 21:59:02 +0100
commit917c74f1845c7215c4269a3a2b103cc9a2662637 (patch)
treeeee8156d20256c38d4671f9d53f8325cc64c8dab /dev-ml/ppx_sexp_value/ppx_sexp_value-113.24.00.ebuild
parentdev-ml/ppx_fields_conv: initial import; ebuild by me (diff)
downloadgentoo-917c74f1845c7215c4269a3a2b103cc9a2662637.tar.gz
gentoo-917c74f1845c7215c4269a3a2b103cc9a2662637.tar.bz2
gentoo-917c74f1845c7215c4269a3a2b103cc9a2662637.zip
dev-ml/ppx_sexp_value: initial import; ebuild by me
Package-Manager: portage-2.2.27 Signed-off-by: Alexis Ballier <aballier@gentoo.org>
Diffstat (limited to 'dev-ml/ppx_sexp_value/ppx_sexp_value-113.24.00.ebuild')
-rw-r--r--dev-ml/ppx_sexp_value/ppx_sexp_value-113.24.00.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-ml/ppx_sexp_value/ppx_sexp_value-113.24.00.ebuild b/dev-ml/ppx_sexp_value/ppx_sexp_value-113.24.00.ebuild
new file mode 100644
index 000000000000..5d69b0b8e6b8
--- /dev/null
+++ b/dev-ml/ppx_sexp_value/ppx_sexp_value-113.24.00.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+DESCRIPTION="Standard library for ppx rewriters"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="dev-ml/ppx_tools:=
+ dev-ml/ppx_core:=
+ dev-ml/ppx_driver:=
+ dev-ml/ppx_here:=
+ dev-ml/ppx_sexp_conv:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam"
+
+src_configure() {
+ emake setup.exe
+ OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
+}
+
+src_compile() {
+ emake
+}
+
+src_install() {
+ opam-installer -i \
+ --prefix="${ED}/usr" \
+ --libdir="${D}/$(ocamlc -where)" \
+ --docdir="${ED}/usr/share/doc/${PF}" \
+ ${PN}.install || die
+}