summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristoph Junghans <junghans@gentoo.org>2022-07-11 23:01:56 -0600
committerChristoph Junghans <junghans@gentoo.org>2022-07-11 23:06:57 -0600
commit7996e989b526cd3249eff05c7d65de3e0e984c49 (patch)
tree7db66e7c56aeba6c5a2505497194dca5d4d0d780 /dev-ml/ptime
parentmedia-sound/rosegarden: removed obsolete 21.12 (diff)
downloadgentoo-7996e989b526cd3249eff05c7d65de3e0e984c49.tar.gz
gentoo-7996e989b526cd3249eff05c7d65de3e0e984c49.tar.bz2
gentoo-7996e989b526cd3249eff05c7d65de3e0e984c49.zip
dev-ml/ptime: initial commit
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Christoph Junghans <junghans@gentoo.org>
Diffstat (limited to 'dev-ml/ptime')
-rw-r--r--dev-ml/ptime/Manifest1
-rw-r--r--dev-ml/ptime/metadata.xml35
-rw-r--r--dev-ml/ptime/ptime-1.0.0.ebuild32
3 files changed, 68 insertions, 0 deletions
diff --git a/dev-ml/ptime/Manifest b/dev-ml/ptime/Manifest
new file mode 100644
index 000000000000..226a8a6d13f4
--- /dev/null
+++ b/dev-ml/ptime/Manifest
@@ -0,0 +1 @@
+DIST ptime-1.0.0.tbz 33749 BLAKE2B 6765924f624a92c69495883accd47c66294f49e2d2841fafc66444369b97b9dceaecac0c00a14cba2e8e710bf85c6d5759f419e83d4d0a7bee56c197d06bb000 SHA512 df2410d9cc25a33083fe968a584b8fb4d68ad5c077f3356da0a20427e6cd8756a5b946b921e5cf8ed4097f2c506e93345d9dca63b113be644d5a7cc0753d1534
diff --git a/dev-ml/ptime/metadata.xml b/dev-ml/ptime/metadata.xml
new file mode 100644
index 000000000000..13860735d090
--- /dev/null
+++ b/dev-ml/ptime/metadata.xml
@@ -0,0 +1,35 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription lang="en">Ptime has platform independent POSIX time support in pure OCaml. It
+provides a type to represent a well-defined range of POSIX timestamps
+with picosecond precision, conversion with date-time values,
+conversion with [RFC 3339 timestamps][rfc3339] and pretty printing to
+a human-readable, locale-independent representation.
+
+The additional Ptime_clock library provides access to a system POSIX
+clock and to the system's current time zone offset.
+
+Ptime is not a calendar library.
+
+Ptime has no dependency. Ptime_clock depends on your system library or
+JavaScript runtime system. Ptime and its libraries are distributed
+under the ISC license.
+
+[rfc3339]: http://tools.ietf.org/html/rfc3339
+
+Home page: http://erratique.ch/software/ptime</longdescription>
+ <upstream>
+ <doc>https://erratique.ch/software/ptime/doc/</doc>
+ <bugs-to>https://github.com/dbuenzli/ptime/issues</bugs-to>
+ <remote-id type="github">dbuenzli/ptime</remote-id>
+ <maintainer>
+ <name>Daniel Bünzli</name>
+ <email>daniel.buenzli@erratique.ch</email>
+ </maintainer>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/ptime/ptime-1.0.0.ebuild b/dev-ml/ptime/ptime-1.0.0.ebuild
new file mode 100644
index 000000000000..49d8a2f7ff44
--- /dev/null
+++ b/dev-ml/ptime/ptime-1.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit opam findlib
+
+DESCRIPTION="POSIX time for OCaml"
+HOMEPAGE="
+ https://erratique.ch/software/ptime
+ https://github.com/dbuenzli/ptime
+ https://opam.ocaml.org/packages/ptime/
+"
+SRC_URI="https://erratique.ch/software/ptime/releases/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND=""
+DEPEND="
+ ${RDEPEND}
+ dev-ml/topkg
+"
+BDEPEND="dev-ml/ocamlbuild"
+
+OPAM_FILE=opam
+
+src_compile() {
+ ocaml pkg/pkg.ml build || die
+}