summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2017-08-06 14:30:17 +0200
committerAlexis Ballier <aballier@gentoo.org>2017-08-06 14:30:28 +0200
commit36f20f5cff468ad6fa8bdfd865707418ca3d4c45 (patch)
tree80f88a83885788ffc845bf3dfd02109be61d43ec /dev-ml/reactiveData/reactiveData-9999.ebuild
parentdev-ml/reason: update to opam.eclass (diff)
downloadgentoo-36f20f5cff468ad6fa8bdfd865707418ca3d4c45.tar.gz
gentoo-36f20f5cff468ad6fa8bdfd865707418ca3d4c45.tar.bz2
gentoo-36f20f5cff468ad6fa8bdfd865707418ca3d4c45.zip
dev-ml/reactiveData: update to opam.eclass
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-ml/reactiveData/reactiveData-9999.ebuild')
-rw-r--r--dev-ml/reactiveData/reactiveData-9999.ebuild17
1 files changed, 4 insertions, 13 deletions
diff --git a/dev-ml/reactiveData/reactiveData-9999.ebuild b/dev-ml/reactiveData/reactiveData-9999.ebuild
index dfdc2e18f2e6..a74fc715fcf0 100644
--- a/dev-ml/reactiveData/reactiveData-9999.ebuild
+++ b/dev-ml/reactiveData/reactiveData-9999.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2016 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
+inherit opam
+
DESCRIPTION="Functional reactive programming with incremental changes in data structures"
HOMEPAGE="https://github.com/ocsigen/reactiveData"
@@ -20,11 +22,9 @@ LICENSE="LGPL-3-with-linking-exception"
SLOT="0/${PV}"
IUSE="+ocamlopt"
-RDEPEND=">=dev-lang/ocaml-3.12:=[ocamlopt?]
- dev-ml/react:="
+RDEPEND="dev-ml/react:="
DEPEND="${RDEPEND}
dev-ml/findlib
- dev-ml/opam
dev-ml/ocamlbuild
"
@@ -34,12 +34,3 @@ src_compile() {
native-dynlink=$(usex ocamlopt true false) \
|| die
}
-
-src_install() {
- opam-installer \
- --prefix="${ED}/usr" \
- --libdir="${D}/$(ocamlc -where)" \
- --docdir="${ED}/usr/share/doc/${PF}" \
- || die
- dodoc README.md
-}