summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2022-06-28 17:05:30 +0200
committerMaciej Barć <xgqt@gentoo.org>2022-06-28 17:18:59 +0200
commit6780ffdad8f8c0323318f72badb81c3eaaa909b0 (patch)
tree809ac501e8c9a0fa3abc98f00b197a8b31919775 /dev-ml/reason/reason-3.8.1.ebuild
parentmedia-gfx/asymptote: bump to 2.81 (diff)
downloadgentoo-6780ffdad8f8c0323318f72badb81c3eaaa909b0.tar.gz
gentoo-6780ffdad8f8c0323318f72badb81c3eaaa909b0.tar.bz2
gentoo-6780ffdad8f8c0323318f72badb81c3eaaa909b0.zip
dev-ml/reason: bump to 3.8.1
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-ml/reason/reason-3.8.1.ebuild')
-rw-r--r--dev-ml/reason/reason-3.8.1.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-ml/reason/reason-3.8.1.ebuild b/dev-ml/reason/reason-3.8.1.ebuild
new file mode 100644
index 000000000000..29a823b9621d
--- /dev/null
+++ b/dev-ml/reason/reason-3.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Simple, fast & type safe language that leverages JavaScript and OCaml"
+HOMEPAGE="https://reasonml.github.io"
+SRC_URI="https://github.com/reasonml/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="+ocamlopt"
+
+RDEPEND="
+ dev-ml/fix:=
+ dev-ml/menhir:=
+ dev-ml/merlin-extend:=
+ dev-ml/ocaml-migrate-parsetree:=
+ dev-ml/result:=
+ dev-ml/utop:=
+"
+DEPEND="${RDEPEND}"
+
+DOCS=(
+ CODE_OF_CONDUCT.md HISTORY.md ORIGINS.md PLAN README.md
+ docs/GETTING_STARTED_CONTRIBUTING.md
+ docs/TYPE_PARAMETERS_PARSING.md
+ docs/USING_PARSER_PROGRAMMATICALLY.md
+)
+
+src_install() {
+ dune-install reason rtop
+ einstalldocs
+}