summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Kitover <rkitover@gmail.com>2020-06-12 03:18:29 +0000
committerJoonas Niilola <juippis@gentoo.org>2020-06-24 13:25:33 +0300
commit4f065399f833906fb55b214693bab8cd96a82fac (patch)
tree2334c169004fb22296a3023141ec50bea13f4100 /dev-ml/stdlib-shims
parentdune.eclass: new eclass (diff)
downloadgentoo-4f065399f833906fb55b214693bab8cd96a82fac.tar.gz
gentoo-4f065399f833906fb55b214693bab8cd96a82fac.tar.bz2
gentoo-4f065399f833906fb55b214693bab8cd96a82fac.zip
dev-ml/stdlib-shims: new package 0.2.0
This is a dependency of dev-ml/ocaml-fileutils-0.6.2. Using the new dune.eclass. Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Rafael Kitover <rkitover@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-ml/stdlib-shims')
-rw-r--r--dev-ml/stdlib-shims/Manifest1
-rw-r--r--dev-ml/stdlib-shims/metadata.xml26
-rw-r--r--dev-ml/stdlib-shims/stdlib-shims-0.2.0.ebuild17
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/stdlib-shims/Manifest b/dev-ml/stdlib-shims/Manifest
new file mode 100644
index 000000000000..e61e7814fb14
--- /dev/null
+++ b/dev-ml/stdlib-shims/Manifest
@@ -0,0 +1 @@
+DIST stdlib-shims-0.2.0.tbz 15980 BLAKE2B 4d83b8642a4bccc9f090c0a2f23a4d2f16bbf2ec686ab41e357f5f544d659e82f10cba85f9d578c939a2a874d0006b7fd17846bb8ffe1b6fc7cb760e4aa33db1 SHA512 19e8d8e004583e94ce060d3598c886dae1c24dd79dfd177aab4bd2865846f668a83071f087d9371393f226c14c90042eb2ec76619654c655995aeff9d4765621
diff --git a/dev-ml/stdlib-shims/metadata.xml b/dev-ml/stdlib-shims/metadata.xml
new file mode 100644
index 000000000000..bf7379a1dd2b
--- /dev/null
+++ b/dev-ml/stdlib-shims/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ Compatibility library for OCaml compilers before 4.08 to allow calling
+ Pervasives module functions on Stdlib, which is the API in newer compilers.
+ Does not add newer Stdlib functions.
+ </longdescription>
+ <maintainer type="person">
+ <email>rkitover@gmail.com</email>
+ <name>Rafael Kitover</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">ocaml/stdlib-shims</remote-id>
+ </upstream>
+ <use>
+ <flag name="ocamlopt">
+ Whether the OCaml native code compiler is used. Must be set globally and
+ match dev-lang/ocaml.
+ </flag>
+ </use>
+</pkgmetadata>
diff --git a/dev-ml/stdlib-shims/stdlib-shims-0.2.0.ebuild b/dev-ml/stdlib-shims/stdlib-shims-0.2.0.ebuild
new file mode 100644
index 000000000000..bedd6b873ecc
--- /dev/null
+++ b/dev-ml/stdlib-shims/stdlib-shims-0.2.0.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit dune
+
+DESCRIPTION="Pure OCaml library that allows replacing Pervasives with Stdlib before 4.08"
+HOMEPAGE="https://github.com/ocaml/stdlib-shims"
+SRC_URI="https://github.com/ocaml/${PN}/releases/download/${PV}/${P}.tbz"
+
+LICENSE="LGPL-2.1-with-linking-exception"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="ocamlopt"
+
+DOCS=( "README.md" "CHANGES.md" "LICENSE" )